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Preface 
Your website may contain different online forms like survey forms, feedback forms, enquiry forms, 

registration forms and so on. When a form is submitted online, the data in the form is sent as email to your 
default email client.  

You need to extract the contact details and other information from the email forms and save the data in your 
database application for follow up. 

eMail-Lead Grabber Business transfers the data available in the email form into your database 
automatically. This enables you to eliminate manual data entry, avoid hassle in processing the web forms 
and to follow up the leads efficiently. 

This guide explains you how to setup eMail-Lead Grabber to transfer data from the email forms to your 
application. 

This is a one-time setup and then eMail-Lead Grabber starts transferring the email data automatically into 
your destination application. 

What is on the CD? 

The eMail-Lead Grabber Business 2010 CD contains the following: 

Item Description 

eMail-Lead Grabber Business Installation 
files 

Files required to install eMail-Lead Grabber Business 2010. 

Quick Start Guide Quick Start Guide provides a short tour about the Software. 

ReadMe.Txt Text file that provides technical information. 

Sample Web Form Email Messages To get familiar with the product, you can use the sample 
messages to test the transfer of information. 

Sample Templates You can test the transfer of information using the sample 
templates. 

Conventions  

The following conventions are used in the guide: 

Convention Description 

Figures Illustrations to understand the features of eMail-Lead Grabber. 

Cross-reference Cross-references are provided as hyperlinks for easy navigation. 

  Note: Important or supplemental information. 

  Tip: Suggestions that are supportive. 

 Warning: A caution message. 
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1. Key Features 
� Automatic data entry: Transfers contact details from different web forms into your database 

application automatically. 

� Works with existing Forms: eMail-Lead Grabber is independent of scripts used in your web 
site and works with your existing web forms. 

� Works with existing Email setup: eMail-Lead Grabber can download email from your existing 
Email client. You can also send email using eMail-Lead Grabber.  

� Checks for duplicates: eMail-Lead Grabber can check for duplicate records while transferring 
into your contact manager. 

� Schedule Activities: You can schedule activities automatically for the transferred contact. 

� Imports email from different sources: Using the Import Toolbar component, you can import 
email from popular email clients / server / Windows Explorer into different applications. 

� Exports data as CSV files: Export the form details to text files in tab separated or comma 
separated formats. This can be imported into any application that supports these formats. 

� Send Automatic response: You can send customized auto-responses to a contact. By merging 
values in the email with a pre-defined message, you can customize this auto-response.  

� Generate Customer ID: You can create a Ticket number/unique ID for each contact. This 

Unique ID can be added in your auto-response and your customer can use this for future 
correspondence. 

� Save E-mail Content: You can save the email contents as a text file and attach to the 
transferred contact record. 

� Auto-distribute E-mail: You can distribute the email to your sales team members using Round 
Robin Forwarding for effective follow-up. 

� Search for Keywords: You can search for any keyword related to your business activity in the 
transferred email form. The search results can be saved in the specified fields of your database. 

� Handle Bounce email: When an email is bounced, you can mark the bounced email ID in your 
database. This enables you to avoid future correspondence with the invalid email ID. 

2. Supported Applications 
eMail-Lead Grabber Business 2010 supports the following applications: 

♦ Access 2003 / 2002 / 2000 

♦ ACT! 2010 / 2009 / 2008 / 2007 / 2006 / 2005 / 6.0 / 2000 

♦ Microsoft Excel 2007/2003 / 2002 / 2000 

♦ GoldMine 7.x / 6.x / 5.x 

♦ Microsoft Outlook 2007/2003 / 2002 / 2000  

♦ Data Export  
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You can download the email forms from the following email clients: 

♦ Microsoft Outlook 2007/2003/2002/2000 

♦ Outlook Express 5.5/5.0/4.72/4.71 

♦ GoldMine E-mail Center 

♦ Windows Messaging 4.0 

♦ Netscape Communicator 4.7/4.5/4.04 

♦ AOL and Other email clients 

3. eMail-Lead Grabber – Setup Wizard 
After installation, the Setup Wizard appears that guides through the setup process of eMail-Lead Grabber. 

The Setup Wizard consists of three steps. 

 

Figure 1: Setup Wizard 

Step 1: Click here to setup eMail-Lead Grabber to download email messages from your default email client. 

The setup email wizard appears and guides you through the process of downloading email messages from 
selected email client. Refer to Chapter 5 for downloading email from various email clients. The settings that 
appear in the wizard are similar to the options explained in this chapter. 

Step 2: Click here to launch the Template Wizard that guides you through the process of creating a 
template. You need to create a template to map the fields that appear in your email form with the fields 
available in your destination. Refer to Chapter 12 for creating templates. 

Step 3: Click here to create a filter. The Create Filter wizard guides you through the process of creating a 
filter with specific criteria and to setup the actions to be performed when the condition is satisfied. You need 

to create a filter to separate appropriate email messages and to transfer them to relevant templates. Refer to 
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Chapter 18 to setup a filter. The settings that appear in the Create Filter wizard are similar to the options 
explained in this chapter. 

Launch at Startup: By default this option is selected. Whenever you launch eMail-Lead Grabber, the Setup 

Wizard is launched. Clear this checkbox to disable the wizard being displayed. You can access this wizard 
from the File > Quick Setup Wizard menu. 

 You can also Cancel this wizard and setup the options manually.  

For best results, you can complete the above steps sequentially. Once you finish the wizard steps,  eMail-
Lead Grabber automatically downloads the email forms from your default email client, filters appropriate 
messages and transfers the contact details to selected destination application.  

4. eMail-Lead Grabber - Components 
eMail-Lead Grabber contains three major components.  

eMail-Lead Grabber Business: Once you install and launch eMail-Lead Grabber, this window is displayed. 

This window appears similar to an email client and contains mailboxes like Inbox, Outbox and Trash. You 
can download your email messages into the Inbox available in eMail-Lead Grabber. You can also check for 
mail, send, reply to and forward email as you do with an email client. 

 

Figure 2: eMail-Lead Grabber Window 

The eMail-Lead Grabber also contains Form Processing Center that displays the templates. You can 
launch the TemplateMaker, Import Toolbar and create filters from this window.  

You can setup to download the email forms from your default email client into the Inbox available in eMail-
Lead Grabber. 

Import Toolbar: You can use the Import Toolbar to transfer the email from your email client to Inbox in 
eMail-Lead Grabber or directly to your application. 
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TemplateMaker: You can use this component to create templates. The templates enable you to map the 
fields available in your email form with the fields in your application.  

These components are explained in detail in the following sections. 

5. Setup to download email into eMail-Lead Grabber  
You can download the email forms from your default email client into eMail-Lead Grabber Inbox.  

Click the Accounts option available in the eMail-Lead Grabber toolbar. 

[OR] 

Click Tools > Accounts. 

In the Account Setup dialog box, click Add and select your email client. 

 

Figure 3: Account Setup 

You can setup to download from the following email clients. 

♦ GoldMine 

♦ IMAP 

♦ Microsoft Outlook 

♦ Outlook Express 

♦ POP3 

5.1. Setup to download from GoldMine 

To download the email from GoldMine,  

Click Add > GoldMine in the Account Setup dialog box. 

In the GoldMine Personality Settings dialog box, enter the following details: 
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Under GoldMine Login Details, 

� Click Get Values from GoldMine to retrieve the following details automatically. 

� Sys Dir: Installation path of the GoldMine and the location of the License database file. 

� Gold Dir:  Location of the Calendar database file that contains a record for each scheduled 
activity. 

� Common Dir:  Location of the Contact database file that contains the main fields of contact 
records. 

� User Name:  Login name of your GoldMine database. 

� Password: Enter your GoldMine database password.  

 

Figure 4: Personality Settings - GoldMine  

Under Personality Settings, 

♦ Personality Name: Enter a name for the email messages to be downloaded. This name is provided to 
differentiate specific type of messages when you receive different type of email forms. For Example, 
you can provide the personality name as “Feedback Forms” to download the email forms that contain 
feedbacks. 

♦ Import Mailbox: Click the  button to select the mailbox from which you want to download the email 
forms.  

♦ Export Mailbox: Click the  button to select the mailbox to which you want to save the processed 
email forms.  After downloading email from GoldMine, the email forms are moved to the Export 
Mailbox. You can create a new folder to save the processed email forms. 

♦ Poll Personality: Select this option to download the email from GoldMine to eMail-Lead Grabber Inbox 
automatically. 

Click OK. 
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5.2. Setup to download using IMAP Server 

To download the email using IMAP server,  

Click Add > IMAP in the Account Setup dialog box. 

In the POP3 Personality Settings dialog box, enter the following details: 

 
Figure 5: Personality Settings - IMAP 

♦ Personality Name: Enter a name for the email messages to be downloaded. 

♦ Incoming Mail Server: Enter your Incoming mail server name. 

♦ User Name: Enter login name of your IMAP account. 

♦ Password: Enter your IMAP account password. 

♦ Polling Mailbox: Click the  button to select the mailbox from which you want to download the email 
forms.  

♦ Return Address:  Enter your email address. 

♦ Outgoing SMTP Server: Enter your Outgoing mail server name. 

♦ Poll Personality: Select this option to download the email from POP3 server to eMail-Lead Grabber 
Inbox automatically. 

♦ More Settings: Click here to configure the SMTP server to send mail. As you click More Settings, the 
E-mail Settings dialog box is displayed. 

In the Outgoing Server tab, make the following settings: 
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Figure 6: Email settings - Outgoing Server 

Select My Outgoing Server (SMTP) requires authentication to ensure SMTP server authentication before 
sending e-mail.  Specify the method of authentication by selecting any one of the following options: 

♦ Select Use Same Settings as my incoming mail server if you want to use the login and password 
details of incoming mail server (POP3). 

♦ Select Log on using if the SMTP server requires a different user name and password. Enter the 
following details: 

� User Name: Enter the user name of your SMTP server. 

� Password: Enter the password of your SMTP server. 

Click OK to save the settings. 

In the Advanced tab, you can make the following settings: 

 
Figure 7: Email settings - Advanced 
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Under Server Port Numbers,  

� Incoming Server (IMAP): The port number of your Incoming Server (IMAP) is displayed by default.  

� Outgoing Server: The port number of your Outgoing Server (SMTP) is displayed by default. 

Click Use Defaults to use the default port numbers. 

 You can also change the port numbers. 

Under Server Timeouts, specify the time interval by moving the slider. (The time varies from 30 seconds to 

6 minutes). The time indicates how long to wait for a response from the server. Specify short time if your 
server is fast and long-time if the server is slow or busy. 

Click OK to save the settings. 

5.3. Setup to download from Microsoft Outlook 

To download the email from Microsoft Outlook,  

In the Account Setup dialog box, 

Click Add > Outlook 2007 / 2003 / 2002 to download from Microsoft Outlook 2007 / 2003 / 2002. 

In the Outlook Mail Personality Settings dialog box, enter the following details: 

 

Figure 8: Personality Settings - Outlook 2007 / 2003 / 2002 

♦ Mail Personality 

♦ Personality name: Enter a name for the email messages to be downloaded. 

♦ Polling Mailbox: Click the  button to select the mailbox from which you want to download the email 
forms.  

♦ Processed Mailbox:  Click the  button to select the mailbox to which you want to save the 
processed email forms.   

♦ Return address: Enter your email address. 

♦ SMTP server: Enter your outgoing mail server name. 
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♦ Poll personality: Select this option to download the email from Outlook to eMail-Lead Grabber Inbox 
automatically. 

♦ Import sender’s e-mail address: Select this option to display the sender’s email ID in the From 
column of eMail-Lead Grabber Inbox. 

♦ Import sender’s display name: Select this option to display the sender’s display name in the From 
column of eMail-Lead Grabber Inbox. 

♦ Date received on mail server:  Select this option so that the Received Date in the Inbox is retrieved 
from the date on which mail is received by the mail server. 

♦ Date delivered into Outlook mailbox: Select this option so that the Received Date in the Inbox is 
retrieved from date on which mail is received by Outlook mailbox. 

Click OK. 

Click Add > Microsoft Outlook to download from Microsoft Outlook 2000. 

In the Outlook Mail Personality Settings dialog box, the details to be entered are similar to Outlook 2007 / 
2003 / 2002, except the following: 

 

Figure 9: Personality Settings – Outlook 2000 

♦ Import Personality Display Name: Select this option to display the sender’s display name in the 
From column of eMail-Lead Grabber Inbox. 

♦ Import Personality Email Address: Select this option to display the sender’s email ID in the From 
column of eMail-Lead Grabber Inbox. 

Click OK. 

5.4. Setup to download from Outlook Express 

To download the email from Outlook Express,  

Click Add > Outlook Express in the Account Setup dialog box. 

In the Outlook Mail Personality Settings dialog box, enter the following details: 
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Figure 10:  Personality Settings – Outlook Express 

♦ Personality Name: Enter a name for the email messages to be downloaded. 

♦ Polling Mailbox: Click the  button to select the mailbox from which you want to download the email 
forms.  

♦ Processed Mailbox:  Click the  button to select the mailbox to which you want to save the 
processed email forms.   

♦ Return Address: Enter your email address. 

♦ SMTP Server: Enter your outgoing mail server name. 

♦ Poll Personality: Select this option to download the email from Outlook Express to eMail-Lead 
Grabber Inbox automatically. 

Click OK. 

 When you download email from Outlook Express or Outlook, the email messages are deleted from the selected folder. 

So, it is recommended not to use your Inbox as the Polling mailbox.  

Create a separate folder in your email client to save the email leads. You can set a filter to automatically move the email 

leads to the specific folder or drag and drop the email leads from your Inbox to the folder. You can use this folder as the 

Polling Mailbox. 

5.5. Setup to download using POP3 Server 

To download the email using POP3 server,  

Click Add > POP3 in the Account Setup dialog box. 

In the POP3 Personality Settings dialog box, enter the following details: 
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Figure 11: Personality Settings - POP3 

♦ Personality Name: Enter a name for the email messages to be downloaded. 

♦ Login Name: Enter login name of your POP3 account. 

♦ Password: Enter your POP3 account password. 

♦ Return Address:  Enter your email address. 

♦ Incoming (POP3) Mail Server: Enter your Incoming mail server name. 

♦ Outgoing (SMTP) Mail Server: Enter your Outgoing mail server name. 

♦ Delete mail from server after download: Select this option to delete the messages available in your 
POP3 server after downloading them into eMail-Lead Grabber. 

♦ Poll Personality: Select this option to download the email from POP3 server to eMail-Lead Grabber 
Inbox automatically. 

♦ Ignore Incoming mail above:  Enter size limitation for incoming messages. The messages that 
exceed the size you have defined here are not downloaded into eMail-Lead Grabber. 

♦ More Settings: Click here to configure the SMTP server to send mail. As you click More Settings, the 
E-mail Settings dialog box is displayed. 

In the Outgoing Server tab, the settings are similar to the IMAP settings. Refer to IMAP for details. 

In the Advanced tab, you can make the following settings: 



Setup to download email into eMail-Lead Grabber 

Page 13 

 
Figure 12: Email settings - Advanced 

Under Server Port Numbers,  

� Incoming Server: The port number of your Incoming Server (POP3) is displayed by default.  

� Outgoing Server: The port number of your Outgoing Server (SMTP) is displayed by default. 

Click Use Defaults to use the default port numbers. 

 You can also change the port numbers. 

Under Server Timeouts, specify the time interval by moving the slider. (The time varies from 30 seconds to 

6 minutes). The time indicates how long to wait for a response from the server. Specify short time if your 
server is fast and long-time if the server is slow or busy. 

Under Email Compression Setting, select the Enable Email Compression Settings checkbox to 
download e-mail from Microsoft Exchange v5.5 Server. 

� Enter the Email Compression Order number to download the complete email from Microsoft 

Exchange. You can increase or decrease the compression order number according to the size of your 
Microsoft Exchange server. The default number is 4. 

Click OK to save the settings. 

5.6. Personality Settings 

After you enter details and save the personality settings, the personality name is displayed in the Account 
Setup dialog box. 
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Figure 13: Account Setup for GoldMine 

♦ Click Remove to delete the personality settings. 

♦ Click Properties to edit the settings. 

♦ Click Test to test the settings. The email forms are downloaded to the eMail-Lead Grabber Inbox. 

♦ Set as default: Click here to make the selected personality name as your default account. When you 
reply to a message or send an auto-response, this account is used for sending the email. 

♦ Options: Click here to open the Miscellaneous Setup dialog box. You can setup to check for email 
messages automatically. This option is explained in detail in the next section. 

Click Close. 

 You can also make use of Step 1 in the setup wizard to download the email messages. The wizard provides step-by-

step instructions to complete the setup. 

6. Download email into eMail-Lead Grabber 
After you have setup your Account, you can start downloading email forms from your email client. 

To download the email forms manually,  

� Click Check Mail in the eMail-Lead Grabber Business toolbar. 

[OR] 

� Click Check Mail in the File menu. 

The email forms are downloaded from your email client as you have setup and saved in eMail-Lead 
Grabber Inbox. 

To download the email forms automatically, you need to setup the Miscellaneous option. 

� Click Tools > Options. 

� In the Miscellaneous Setup dialog box, make the following settings: 
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Figure 14: Miscellanous Setup 

� Check for new messages at startup:  Select this option to check for email whenever you launch 
eMail-Lead Grabber. 

� Show popup when new message arrives: Select this option to be notified whenever you receive 
new email. 

� Show Alert for mailbox Compaction: Select this option to get a message for compaction whenever 

your mailbox exceeds a limit of 45 MB. This option is selected by default. To disable the warning 
message, you can clear this checkbox. 

� Automatically download new messages: Select this option to check for email at specified time 
interval. Enter the time in minutes in the space provided. 

� Use System Date Time format:  Select this option to display the date as per your System settings. If 
this option is not selected, then the date is displayed in the default format as ‘MM/DD/YY’. 

� Click Setup Login to setup login restrictions for eMail-Lead Grabber.  

� In the User Login dialog box that appears, enter User Name and Password 

� Re-enter the password in Confirm Password. 

� Click OK. 

� Use Outlook: Select this checkbox to send email using Microsoft Outlook. Enter the Profile Name and 
Password to send email through secured authentication. 

Click OK to save the settings. 

Now the email is checked automatically in the specified time interval. 

 Ensure that the Poll Personality checkbox is selected in the Personality Settings to download the email. If you enter 

the time interval as zero (0), then email is not checked. 

Next, you need to create a template to process the downloaded email messages and to transfer the details 

to your destination. Refer to TemplateMaker to create a template. 
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7. Working with eMail-Lead Grabber  
eMail-Lead Grabber window contains the following to manipulate the messages. 

♦ Menu bar 

♦ Toolbar 

♦ Status bar 

♦ Report bar 

You can make use of the above components to send, reply or forward the messages. You can launch the 

Import Toolbar that can be used to download messages from other email clients. You can also launch the 
Template Maker to create templates. 

7.1. eMail-Lead Grabber - Menu bar 

The eMail-Lead Grabber menu bar contains the following commands: 

File Menu 

Option Function 

Check Mail Checks e-mail and download new e-mail to the Inbox. 

New Folder Create a new folder in Email Center.  

New Mailbox Create a new mailbox in Email Center.  

Print Print selected message. 

Quick Setup Wizard Launch the Setup Wizard 

Show Import Toolbar Launch the eMail-Lead Grabber- Import Toolbar. 

Show Template Wizard Launch the Template Wizard to create templates. 

Show Template Maker Launches TemplateMaker to create templates.  

Exit Quit eMail-Lead Grabber. 

Edit Menu  

Option Function 

Undo Reverts the last performed action. 

Cut Removes the selected text and places it in the Clipboard. 

Copy Copies the selected text to the Clipboard. 

Paste Inserts the contents of Clipboard. 

Find Opens the Find Message dialog box and enables you to search for messages. 

Select All Selects all the contents of a message. 
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View Menu  

Option Function 

Toolbar Show or Hide the eMail-Lead Grabber Toolbar. 

Status Bar Show or Hide the Status Bar. 

Report Bar Show or Hide the Report Bar.  

Folder View Show or Hide the folders displayed in the Folders view. 

Task Status Show the Task Status tab displayed in the Report Bar.  

Process Status Show the Process Status tab in the Report Bar.  

Errors Show the Errors tab in the Report Bar.  

Refresh View  To update and reflect the changes made to the folders displayed in the current 
view. 

 Message Menu 

Option Function 

Compose Create a new message.  

Reply Reply to the sender of the selected message.  

Reply All Reply to all in the TO and CC columns of the selected message. 

Forward Forward selected message.  

Delete Delete selected messages.  

Import Messages Import messages from the default email client. 

 

Folders Menu 

Option Function 

Inbox Displays the Inbox. 

Outbox Displays the Outbox.  

Trash Displays the Trash. 

User Folders Select the sub folders and mailboxes within folders, if available. 

Form Processing Center Displays all the templates. Click the template name to view the messages 
processed using the same. 

 



Working with eMail-Lead Grabber 

Page 18 

Tools Menu  

Option Function 

Filters Create a new filter or edit an exiting filter.  

Accounts Create a new e-mail account in eMail-Lead Grabber. 

User Setup Setup login restrictions to eMail-Lead Grabber. Enter a user name and 
password to login to eMail-Lead Grabber.  

Stationery Create, Edit, or Delete Stationery. 

Register / Unregister 
Template 

Add or remove templates from the Form Processing Center. 

Backup/Compact Launches Dr. Mailbox to maintain your mailboxes. 

Options View the Options dialog box to provide mail settings for all your e-mail 
accounts.  

 

Help Menu 

Option Function 

Help Topics Launches the Help.  

eGrabber on the Web Access Live Update, Online User Guide and FAQs from eGrabber website. 

Demo Launches demo on the product. 

Register/Unregister Product Register or unregister eMail-Lead Grabber. 

About eMail-Lead Grabber Displays eMail-Lead Grabber version and copyright information. 
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7.2. eMail-Lead Grabber - Toolbar 

The eMail-Lead Grabber toolbar contains the following commands: 

Option Function   

 
Check for new email manually. 

 
Setup Accounts. 

 
Launch Setup Wizard. 

 
Setup Filters. 

 
Launch Import Toolbar. 

 
Create new email message. 

 
Reply to the sender of the selected message.  

 
Reply to all in the TO and CC columns of the selected message. 

 
Forward selected message.  

 
Opens the Find Message dialog box and enables you to search for messages. 

 
Delete selected messages.  

 
Re-process an email message 

 
Launches Help 
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7.3. eMail-Lead Grabber - Status bar 

The status bar displays the total number of messages and the number of messages selected in the current 
folder. 

7.4. Report bar 

The report bar displays the status of the processed messages and error messages. This bar contains three 
tabs as follows: 

Task Status: 

Click  or View>Task Status to view this tab.  

 
Figure 15: Task Status 

The task status displays the background activities like retrieving email from your email client, processing 
messages through filters, templates, etc. This tab also displays the progress of a task in percentage. 

 Right-click the Task Status and select Abort Task to stop a task being processed. 

Process Status: 

Click  or View>Process Status to view this tab.  

 
Figure 16: Process Status 

The following details are displayed in the Process Status tab: 

Column Description 

Date Date and time of process. 

Subject Subject of the processed e-mail. 

From The sender’s email ID of the processed e-mail. 

Filter Name of the filter used for processing the e-mail. 

Template Name of the template used for processing the e-mail. 
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Status\Error Displays the Transfer Status. 

If the transfer is successful, the message “Transfer Successful” is displayed. 

If the transfer fails then the error message is displayed with the reason for failure. 

If the transfer is skipped then “Skipped Transfer” is displayed. 

If the e-mail is processed and not transferred then “Process Successful” is displayed. 

 To save the processed details, right-click in the Process tab and select Save Status Log. To clear the text, righ-click 
and select Delete or Delete All. 

Errors: 

Click  or View>Errors to view this tab. 

 
Figure 17: Errors tab 

The errors that occurred during the background process are displayed here. 

 To clear the error messages, righ-click and select Delete. 

7.5. Shortcut Menus 

Right-click on any part of the eMail-Lead Grabber window to access the shortcut menus. 

The shortcut menus vary according to the selected area. For example, if you right click the message grid, 

you can access the shortcut menu as shown in Figure 23Figure 23 

You can use these shortcut menus to quickly access the commands that are available in the menu bar and 
the toolbar. 

8. Using Import Toolbar 
You can download email messages from other email clients using the Import Toolbar. 

To launch the Import Toolbar, 

♦ Click the Import Toolbar Icon in the eMail-Lead Grabber Toolbar. 

[OR] 

♦ Click File > Show Import Toolbar. 

The Import Toolbar appears as shown in Figure 18. 

 
Figure 18: Import Toolbar 

You can select the source from which the email messages to be downloaded from the drop-down list that 
appears on the left panel.  
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The options available in this list are: 

♦ Selected Text 

♦ Text in Clipboard 

♦ Windows Explorer 

♦ Outlook Express 

♦ Outlook 

♦ GoldMine 

♦ Windows Messaging 

♦ Netscape Communicator 

If you are using an email client other than the applications listed above, then you can use the Selected Text / 
Text in Clipboard / Windows Explorer options to download the email messages.  

The right panel displays the option Inbox and the templates created. 

Select the option Inbox to download the messages to eMail-Lead Grabber Inbox or the template to directly 

transfer the details from the selected message to selected destination application. You can find the option to 
create a template in this drop-down list.  

Refer to Chapter 11 for details on creating a template. 

9. Customize Import Toolbar 
You can customize the source and destination options available in the Import Toolbar. 

Click  that appears in the center of the Toolbar to launch the Options dialog box. 

In the Options dialog box, you can setup the source, destination and miscellaneous options. 

9.1. Add / Remove Source Application 

In the Options dialog box, click the Input Source option to add or remove the source applications that are 
displayed in the Import Toolbar. 

The available source applications are displayed in the dialog box.  

To add an application to the toolbar,  

Select the application displayed under Available Sources and click the Add button.  

The application is now displayed under Selected Sources. 
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Figure 19: Add / Remove Source Applications 

To hide an application being displayed in the toolbar, 

Select the application displayed under Selected Sources and click the Remove button.  

The application is now displayed under Available Sources. 

Click OK to save the settings. 

The applications listed under Selected Sources are displayed in the drop-down list on the left panel of the 
toolbar. 

9.2. Add / Remove Destination Application 

In the Options dialog box, click the Destination option to add or remove the templates that are displayed in 
the Import Toolbar. 

The available templates are displayed in the dialog box.  

To add a template to the toolbar,  

Select the template displayed under Available Templates and click the Add button.  

The template is now displayed under Selected Templates. 
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Figure 20: Add / Remove Templates 

To hide a template being displayed in the toolbar,  

Select the template displayed under Selected Templates and click the Remove button.  

The template is now displayed under Available Templates. 

Click OK to save the settings. 

The templates listed under Selected Templates are displayed in the drop-down list on the right panel of the 
toolbar. 

9.3. Miscellaneous Setup 

In the Options dialog box, click Miscellaneous  to setup other options. 

In the Miscellaneous dialog box, you can setup the following options: 

Show Transfer Window: Select this check box to display a transfer window. The transfer window appears 

whenever you process email messages; this window displays the status and number of messages 
processed. 
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Figure 21: Import Toolbar - Miscellaneous Setup 

Under Left mouse click on Tray icon should,  

• Toggle Toolbar between Show and Minimize: Select this option so that when you click on the 
Tray Icon, the Import Toolbar is shown or minimized. 

• Capture using last set source and destination: Select this option so that when you click the Tray 
Icon, the email messages are transferred with the last settings selected in the Import Toolbar. 

Click OK to save the settings. 

10. Download email using Import Toolbar 
Select your email client from the Source list of the Import Toolbar. If your email client is not available in the 

list, select your message manually and select the option Selected Text in the toolbar. You can also transfer 
information from documents available in a folder bys selecting the option Windows Explorer. 

Select the option Inbox in the Destination list to transfer the messages to the eMail-Lead Grabber Inbox. To 
transfer the messages directly to your destination, select the relevant template.  

Now click the Go button in the toolbar. 

The selected messages are transferred according to the selected settings. 

You can create a new template by selecting the option Create Template from the destination list. 

After downloading the email messages to eMail-Lead Grabber Inbox, you need to create templates for 
transferring the information into your destination. 
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11. TemplateMaker 
Your email form contains two major components: Form Tags and the form data.  

� Form tags are the fields available in your email form.  

� Form data is the value filled in by the visitor. 

� You need to map the form tags with the database fields. 

While transferring, the form data is transferred into the mapped fields in the selected application. 

The mapping of fields varies according to the selected destination. 

 
Figure 22: Example for an Email Form 

You can create the templates in two methods: 

1) Wizard Mode 

2) Advanced Mode 
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12. Create Template in Wizard Mode 
Launch the Template Wizard by any one of the following methods: 

� Click Step 2  in the Setup Wizard 

           [OR] 

� Select any email that contains all the form tags, right-click and select Create Template in Wizard 
Mode. (Refer Figure 23) 

           [OR] 

� Right-Click the Form Processing Center and select Create Template Wizard Mode. 

[OR] 

� Click File > Show Template Wizard. 

 
Figure 23: Create Template 

The Template Creation Wizard is launched and this wizard guides you through the process of creating a 
template. 

12.1. Name the Template 

The first step is to name the template. Enter a name and click Next. 
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Figure 24: Enter Template Name 

12.2. Edit Sample Email 

The next step is to view and edit the email form. The selected email text appears in the wizard.  

If you have launched the template wizard by using the File > Show Template Wizard option, then the 

wizard space appears blank. You need to copy and paste your email text that contains all the form tags and 
data (Refer to Figure 22). 

 
Figure 25: View and edit the sample Email 
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You can verify the details and edit them, if required and click Next. 

12.3. Extract tags from Email 

The next step is to extract the form tags from the email. 

You can extract the tags by any one of the following methods: 

Extract Form Tags Automatically: This option is selected by default. The form tags are extracted 
automatically from the selected email. 

The Form Tag separator is displayed automatically next to Tag and  Field Separator. You can also enter 
the tag separator manually. Select the TAB checkbox if there is a tab separator appearing in between the 
form tags and the form data.  

 Tag Separator is the character that separates the form tag and the form data. 

Manual Entry of Form Tags: Select this option to manually enter the form tags from your web form. 

XML Form E-mail: This option is selected by default if your form email is in XML format. 

 
Figure 26: Extarct form tags 

Select the relevant option and click Next. 
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12.4. Customize Anchor Text 
The next step is to customize the anchor text.  The form tags need to be marked as anchor text for mapping 
the fields. 

 
Figure 27: Edit Anchor Text 

If you have selected the option Manual Entry of Form Tags,  you need to enter the anchor text manually. 
Else, the form tags are marked as anchor text automatically and displayed. 

Select an anchor text and click Set Properties to define the properties for the anchor text. Refer to Setup 
Anchor Properties for more details. 

Click View E-mail to view the sample email for reference. 

After customizing the anchor text, click Next. 
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12.5. Select Destination Application 
The next step is to select your destination application. 

 

Figure 28: Select Destination Application 

Select the appropriate destination application from the Select Contact Manager list, and click Next. 

The next step in the wizard varies according to the selected destination.  

The following applications are supported: 

♦ Access 

♦ ACT! 

♦ Microsoft Excel  

♦ GoldMine 

♦ Microsoft Outlook 

12.6. Create Template for Access 

You can create template for the following versions of Microsoft Access. 

♦ Microsoft Access 2003 / 2002 / 2000. 

Select the option Access 2003 / 2002 / 2000 from the Contact Manager list (Refer Figure 28) and click 
Next. 
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12.6.1. Login to Access 
In the next step you need to login to the Microsoft Access database. 

 
Figure 29: Login to Access database 

User Name: Enter the login name of your database. 

Password: Enter the password for the database. 

Database: Click  to browse and select your database. The name and path of the selected database is 
displayed. 

Click Login. 

The “Logged in Successfully” message is displayed. 

Click Next. 
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12.6.2. Select Fields 
The next step is to select the Tables and Fields to which the data is to be transferred. 

The available tables are displayed in the left pane and the corresponding fields in the right pane. 

 
Figure 30: Select Table and Fields 

Select the appropriate table and the corresponding fields and click Next. 

 Click Select All to select all the fields and Clear to deselect all the fields. 
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12.6.3. Map Fields 
The next step is to map the fields available in the selected Access table with the form tags. 

 
Figure 31: Map Access Table Fields 

Double-click the Fields row and select the appropriate database field to map the field manaually. 

Click Auto Map to map the fields automatically. 

Click Clear Map to remove the mapping. 

Click Test Map to view the extracted values from the email. 

Select a field and click Set Properties to define properties for the selected field. Refer to 

Setup_Field_Properties for more details. 

Click View E-mail to view the sample email for reference. 

 To add or remove a form tag, click Add Row or Delete Row respectively. 

After mapping the fields, click Next. 
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12.6.4. Map Email Header Information 
The next step is to extract the email header information and save them in user fields. 

 
Figure 32: Map Email Header Information - Access 

You can save the following information from the email: 

♦ Sent Date. 

♦ Sent Time. 

♦ From Address of the email. 

♦ To Address of the email. 

♦ Subject of the email message. 

Double-click and select the appropriate field to save the above information. 

Copy E-mail to Notes: This option is not available for Access. 

Copy E-mail to History: This option is not available for Access. 

Copy and save E-mail attachments to this Folder: This option is not available for Access. 

After selecting appropriate fields, click Next. 
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12.6.5. Setup to check for duplicates 
The next step is to setup to check for duplicates. 

 
Figure 33: Access - Check for Duplicates 

To handle duplicate records, select any one of the following options: 

• Select Add as new Contact to add the duplicate as a new contact to your application.  

• Select Update if only one contact exist else cancel to update the existing contact in your 
application. This option updates the contact when only one contact is available in your database. If 
more than one record is found, the transfer process is cancelled.  

• Select Warn if contact exists to get a warning message when you transfer a duplicate contact to 

access. During the transfer of a duplicate contact, a Contact Linker dialog box appears as shown 
in Figure 34. 

• Select Cancel if contact exists to cancel transferring the duplicate contact. 

When you select any of the above options except Always add as new contact, the fields under Select 
Fields for Duplicate Check are made available. Select a single field or multiple fields to check for duplicate 
values.   

Contact Linker 

When you select Warn if contact exists option, the Contact Linker dialog box is displayed when duplicate 
contact information is transferred. 
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Figure 34: Contact Linker – Access 

Select To do… 

Add as new contact Adds the duplicate record as a new record in your 
database. 

Update existing contact Updates an existing record with the new incoming details in 
your database. 

Cancel transfer Cancel transferring the duplicate record to your database. 

  If more than one contact exists in the database that matches the incoming record, then the Update option is disabled 

in the above dialog box. In this case, you can select to add the duplicate record as a new record or cancel transferring the 

record to your database. 

After making relevant settings, click Next. 

The next step is to save the email contents to a text file and attach the file to the destination. Refer to 12.11 

Attach Email Contents to proceed with subsequent steps. 

12.7. Create Template for ACT! 

You can create template for the following versions of ACT!. 

♦ ACT! 2010 / 2009 / 2008 / 2007 / 2006 / 2005 / 6.0 / 2000. 

Select your version of ACT! from the Contact Manager list (Refer Figure 28) and click Next. 

12.7.1. Login to ACT! 
In the next step you need to login to the ACT! database. 

Enter the following details in the Login dialog box. 

♦ Database Path: Click  and select the Database path of ACT! database. You can also select Use 
currently open database to detect and display the currently opened ACT! database automatically. 

♦ UserName: Enter the login name of ACT! database. 

♦ Password: Enter the password to access your database. 

Click Login to get access to database. 

The message “Login Successful” appears in the Result area. 
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Figure 35: Login to ACT! 

After logging in successfully, click Next. 

12.7.2. Select User Fields 
The next step is to select the user fields. 

 
Figure 36: Select User Fields 

In this dialog box, all the user fields available in ACT! are displayed as Field Label with the corresponding 
Internal column name. 

Click Refresh if the user fields are not displayed. 
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Select the chekbox next to the user fields to map the data from the email message. Click Select all or Clear 
all to select or deselct all the user fields. 

After selecting appropriate user fields, click Next. 

 This option is available only if you select ACT! 2007 / 2006 / 2005 as destination. For ACT! 6.0/2000, the wizard 

moves to the next step to map the fields. 

12.7.3. Map Fields 
The next step is to map the database fields available in your ACT! database. 

The settings are similar to mapping fields for Access. Refer to Map Fields in Access Template for more 

details. 

After mapping the appropriate fields click Next. 

12.7.4. Map Email Header Information 
The next step is to extract the email header information and save them in user fields. 

 
Figure 37: Map Email Header Information - ACT! 

You can save the following information from the email: 

♦ Sent Date. 

♦ Sent Time. 

♦ From Address of the email. 

♦ To Address of the email. 

♦ Subject of the email message. 

Double-click and select the appropriate field to save the above information. 
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Copy E-mail to Notes: Select this checkbox to copy the contents of the email message to the Notes section 
of ACT!. 

Copy E-mail to History: Select this checkbox to copy the contents of the email message to the History tab 
of ACT!. 

Copy and save E-mail attachments to this Folder: Select this checkbox to save the email attachments. 

Click  to browse and select the folder to save the attachment files.  

After making appropriate settings, click Next. 

12.7.5. Setup to transfer company details 
The next step is to transfer the company records. 

 
Figure 38: ACT! - Transfer Company Details 

You can select the following options: 

Link to Company, if found: Select this option to link the contact information to an existing company (if found) 
in ACT! 

Create Company, if not found: Select this option to create a new company (if not found) in ACT! and link the 
contact information to that company. 

Prompt if a Contact is already linked to a Company:  Select this option to get a message if the conatct is 
already linked to a company. 

Modify company details: Select this option to update the company details on ACT! with the new details 
being transferred. 

After selecting appropriate options, click Next. 
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12.7.6. Setup to check for duplicates 
The next step is to setup to check for duplicates. 

To handle duplicate records, select any one of the following options: 

 

Figure 39: ACT! - Check for Duplicates 

Under Select transfer mode,  

• Select Add as new to add the duplicate as a new contact to your application.  

• Select Update if only one contact exists to update the existing contact in your application. This 
option updates the contact when only one duplicate contact is available in your database. If more 
than one duplicate record is found, the transfer process is cancelled.  

• Select Always update first duplicate record to update the existing contact in your application. 
This option updates the first found existing record when more than one duplicate record is found. 

• Select Warn if contact exists to get a warning message when you transfer a duplicate contact to 

ACT!. During the transfer of a duplicate contact, a Validate Duplicates dialog box appears as 
shown in Figure 40. 

• Select Cancel if contact exists to cancel transferring the duplicate record. 

When you select any of the above options except Add as new, the fields under Check for duplicates in 
Contact based on are made available. Select a single field or multiple fields to check for duplicate values.   

• Contact: Check first and last name of the Contact. 

• Company: Check the value of the company field. 

• Contact: E-mail: Check the e-mail address. 

• Contact: Phone: Check the phone number of the contact. 
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• Contact: Zip: Check the Zip Code of the contact. 

Bring ACT! to Forefront after transfer: Select this option to display the contact record after the transfer 
process. 

Validate Duplicates 

When you select Warn if contact exists option, the Validate Duplicates dialog box is displayed when a 
duplicate contact information is transferred. 

In the Validate Duplicates dialog box, the existing field values and the new incoming values are displayed 
in a tabular format. All the contacts with the duplicate values are displayed. You can browse between the 
contacts and choose to either update the existing contact or add the duplicate as a new contact. 

 
Figure 40: Validate Duplicates 

The following details are displayed in the dialog box: 

Field Name Existing Field Value Field Value in E-mail (New) Select 

Displays all the fields available in 

the database of your destination 

application. 

Displays the existing values 

available in your database. 

Displays the new incoming values 

available in the Email Form. 

Click to toggle 

between ACCEPT or 

REJECT. By default, 

ACCEPT is displayed. 

The Creation Date and Last Modified display the created and last modified dates of the existing record. 

Compare the values, and select the status as ACCEPT or REJECT to accept or reject the new values. 
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Select Reject All to reject all the changes. 

Under Mode of Transfer, 

♦ To update the existing record, select Update.  

♦ To add the incoming values as a new record, select Add as New. 

Click Transfer to transfer the record as per the settings you have made. 

 You can click the navigation buttons (  or ) to browse the records that contain duplicate values. These 

buttons are enabled only when the database contains more than one duplicate record. 

Click Cancel to skip the transfer. 

After selecting appropriate mode to check for duplicates, click Next. 

12.7.7. Schedule and attach Activity 
Next, you can setup to schedule activities like “Meetings, Calls” etc for the transferred contacts. 

You can attach, schedule, and prioritize activities like “Call, Meeting, To-do” for all contacts transferred to 
your ACT! database.  

The attached activities are displayed in the Activities tab of the transferred contact in ACT! . 

 
Figure 41: Schedule and attach Activity in ACT! 

Click the New button to create a new activity. In the Activity Settings, setup the following options to create 
a new activity. 
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Figure 42: Activity Settings - ACT! 

♦ Activity type: Select activity (Call, Meeting, or To-do) from the list. 

♦ No of Days: Enter the number of days counting from the present day when you want to perform the 
activity. For Example, type 30 days to execute the activity on the 30th day counting from the present 
day. 

♦ Time: Enter the time when you want to perform the activity. The current system time is displayed by 

default. Enter a time or click the down arrow to select time. The Time selector displays time slots with 
difference of 30 minutes. 

♦ Duration: Enter the duration of the activity. For Example, if your calls last for 45 minutes, then type 45 
in the Duration box. 

♦ Scheduled With: The name of the contact to which you have scheduled the activity is displayed when 
you transfer records to ACT!. 

♦ Regarding: Select from the list or type a description for the activity. 

♦ Priority: Select High, Medium or Low from the list to prioritize your activity. 

♦ Ring alarm: Set an alarm to remind you of scheduled activity. Select a time from the list. For Example: 

If you select 5 minutes from this list, the alarm pops up 5 minutes before the time at which the activity 
has been scheduled.  

♦ Save activity as: Enter a name to save the activity. 

♦ Confirm before transfer: Select this option to view the scheduled activity when the contact 
information is transferred to ACT! 

♦ Schedule this activity for: This option is available for ACT! 2007 only. The existing database user 
names are displayed in this drop-down list. You can select the user name from this list. The activity is 
attached to the selected user name. 

Click OK to save the settings. 

  The name of the activity is displayed under Attach selected activities while transferring to ACT!. You can create more 

activities by repeating the above steps. You can select/clear the activity names to activate/deactivate the process while 

transferring contact details. 
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Click Refresh to update the changes made to activities. 

To edit an activity:  

Select the activity displayed under Attach selected activities while transferring to ACT! 

♦ Click Edit and make changes in the Activity Settings. 

♦ Click OK. 

To delete an activity:  

Select the activity displayed in the area under Attach selected activities while transferring to ACT! 

♦ Click Delete. 

♦ Click OK. 

After creating required activities, click Next. 

The next step is to save the email contents to a text file and attach the file to the destination. Refer to 12.11 

Attach Email Contents to proceed with subsequent steps. 

12.8. Create Template for Microsoft Excel 

Select the option Excel 2007/2003/2002/2000 from the Contact Manager list (Refer Figure 28) and click 
Next. 

In the next step you can select to transfer the information to an existing or new Excel File. 

12.8.1. Select an Excel File 
Transfer to an existing Excel Workbook: Select this option to transfer contact details to an existing Excel 
file. 

Select the Excel Workbook: Click   next to this option to open an existing Excel file. 

Browse and locate your Excel file. Select the file and click Open. 

Click Next to Select Fields in the existing Excel File. 

 

Figure 43: Select / Create Excel File 
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12.8.2. Select Fields in Excel 
When you select an existing Excel file and click Next, the Select Fields dialog box appears as shown in 
Figure 44. 

The left pane displays all the sheets in the file and the right pane displays the column headings present in 
the selected sheet. 

From the left pane, select the sheet(s) to which you want to transfer your records. The first sheet is selected 
by default. 

The column headings present in the first row of the sheet are displayed by default in the right pane. 

Select the fields to which you want to transfer data from the email form. 

 

Figure 44: Select Excel Fields 

  You can select multiple sheets from your Excel File. Example: Select Sheet1 and select the fields of this sheet in the 
right panel. To select the next sheet click on Sheet2 and select fields from this sheet. When you select Sheet2, the already 

selected Sheet1 appears in blue color. 

Select the row containing the column header: Select the row number that holds the column headings, if 
no fields are displayed under Select Column(s). 

Select the starting row for entering new information: Select the row number from where you want to 
start inserting the transferred records. 

 The values of the row numbers can be different for each sheet. 

Example: For Sheet1 row numbers can be 3,4 and for Sheet 2 the row numbers can be 2,3. 

A sample excel file is shown in Figure 45 that illustrates the row numbers and column headings. 



Create Template in Wizard Mode 

Page 47 

 

Figure 45: Sample Excel File 

Check All: Click here to select all the column headings. 

Clear All: Click here to remove the selection of all the column headings. 

Turn off the warnings while transferring: Select this option to hide the warning messages during transfer. 

Click Next to map the fields. 

12.8.3. Create an Excel File 
Create a new Excel Workbook: Select this option to transfer contact details to a new Excel file. 

Click  next to this option. 

Enter the name of your Excel file. Click Save. A new Excel file is created with the specified name. 

Click Next to Create Excel Fields. 

12.8.4. Create Excel Fields 
After creating a new Excel File, you have to create column headings. 

By default, three sheets of the new Excel file are displayed in the left pane. 

 

Figure 46: Create Excel Fields 
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Select a sheet from the list to which you want to transfer your records. The first sheet is selected by default. 

Click Add/Edit Fields to create column headings for the selected sheet. 

Enter your field names in the Edit Fields dialog box. You can also edit the fields. Click OK to save the data. 

 

Figure 47: Add / Edit Excel Fields 

The field names are displayed under Fields. 

By default, all the column headings are selected. You can select/clear the fields. 

Check All: Click here to select all the column headings. 

Clear All: Click here to remove the selection of all the column headings. 

 

Figure 48: Add / Edit Excel Fields 

The field names are displayed under Fields. 

By default, all the column headings are selected. You can select/clear the fields. 

Select All: Click here to select all the column headings. 

Clear All: Click here to remove the selection of all the column headings. 

Click Next to map the fields. 
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12.8.5. Map Fields 
The next step is to map the database fields available in your Excel Sheet. 

The settings are similar to mapping fields for Access. Refer to in Access Template for more details. 

After mapping the appropriate fields click Next. 

12.8.6. Map Email Header Information 
The next step is to extract the email header information and save them in user fields. 

 
Figure 49: Map Email Header Information - Excel 

You can save the following information from the email: 

♦ Sent Date. 

♦ Sent Time. 

♦ From Address of the email. 

♦ To Address of the email. 

♦ Subject of the email message. 

Double-click and select the appropriate field to save the above information. 

Copy E-mail to Notes: This option is not available for Excel. 

Copy E-mail to History: This option is not available for Excel. 

Copy and save E-mail attachments to this Folder: Select this checkbox to save the email attachments. 

Click  to browse and select the folder to save the attachment files.  

After making appropriate settings, click Next. 

12.8.7. Miscellaneous Setup 
In the next step select the field to which you can link your email attachment from the drop-down list. 
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Figure 50: Miscellaneous Settings - Excel 

Bring Excel to forefront after transfer: Select this option to display the Excel file with the inserted contact 
information after transfer and click Next. 

The next step is to save the email contents to a text file and attach the file to the destination. Refer to 12.11 

Attach Email Contents to proceed with subsequent steps. 

12.9. Create Template for GoldMine 

You can create template for the following versions of GoldMine. 

♦ GoldMine 7.x / 6.x / 5.x 

Select your version of GoldMine from the Contact Manager list (Refer Figure 28) and click Next. 

12.9.1. Login to GoldMine 
In the next step you need to login to the GoldMine database. 

Enter the following details in the Login dialog box. 
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Figure 51: Login to GoldMine 

Click Get GoldMine Details button.  

The following login details are automatically retrieved from GoldMine database and displayed. 

� System Directory: Installation path of the GoldMine and the location of the License database 
file. 

� GoldMine Directory: Location of the Calendar database file that contains a record for each 
scheduled activity. 

� Common Directory: Location of the Contact database file that contains the main fields of 
contact records. 

� UserName: Login name of your GoldMine database. 

Password: Enter the password to access your database. 

Click Login to get access to database. 

The message “Logged in Successfully” is displayed. 

Click Next. 

12.9.2. Select Details 
In the next step, you can select the details fields to which you can transfer data from your email form. All the 
fields from the details tab of your GoldMine database are displayed under Select Detail Fields. 

Select the checkbox next to a detail field name. The detail field displayed is the name of the profile record 
entry, like Credit Card Number. 

Click Select All to select all the fields displayed. All the field names are selected. 

To deselect all the fields, click Clear All. 
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Figure 52: Select Details - GoldMine 

 You can select a maximum of 10 detail fields. 

Click Next. 

12.9.3. Select User Fields 
In the next step, you can select the user fields to transfer data from the email. 

All the user fields available in GoldMine are displayed under Label.  The internal field name of the user 
fields is also displayed. 

Select the checkbox next to a user field name.  

Click Select All to select all the fields displayed. All the field names are selected. 

To deselect all the fields, click Clear All. 
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Figure 53: Select User Fields – GoldMine 

 You can select a maximum of 397 user fields. 

Click Next. 

12.9.4. Map Fields 
The next step is to map the database fields available in your GoldMine database. 

The settings are similar to mapping fields for Access. Refer to Map Fields in Access Template for more 

details. 

After mapping the appropriate fields click Next. 

12.9.5. Map Email Header Information 
The next step is to extract the email header information and save them in user fields. 

The settings are similar to mapping  for ACT!. Refer to Map Email Header Information in ACT! Template for 
more details. 

After making appropriate settings, click Next. 

12.9.6. Setup to check for duplicates 
The next step is to setup to check for duplicates. 

To handle duplicate records, select any one of the following options: 



Create Template in Wizard Mode 

Page 54 

Under Select Transfer Mode,  

• Select Always Add as New Contact to add the duplicate as a new contact to your application.  

• Select Warn if contact exists to get a warning message when you transfer a duplicate contact to 
ACT!. During the transfer of a duplicate contact, a Validate Duplicates dialog box appears as 
shown in Figure 40. 

• Select Always update first duplicate to update the existing contact in your application. This option 
updates the first found existing record when more than one duplicate record is found. 

• Select Update if only one contact exists to update the existing contact in your application. This 
option updates the contact when only one duplicate contact is available in your database. If more 
than one duplicate record is found, the transfer process is cancelled.  

• Select Only Update existing contact to update existing contacts only. This option checks for a 
duplicate record and if no match is found, then the transfer process is cancelled. The contact is not 
added as a new record. 

• Select Cancel if contact exists to cancel transferring the duplicate record. 

 
Figure 54: GoldMine - Check for Duplicates 

When you select any of the above options except Always Add as New Contact, the fields under Select 
Fields To Duplicate Check are made available.  

Select a single field or multiple fields to check for duplicate values.   

Bring GoldMine to the forefront after transfer: Select this option to display the contact record after the 
transfer process. 

After making relevant settings, click Next. 
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12.9.7. Schedule Activity 
The next step is to schedule activities for the transferred contact records. 

 
Figure 55: Attach Activities to GoldMine 

Click New and select an activity to be scheduled from the menu: 

� Call 

� Next Action 

� Appointment 

� Literature Request 

� Forecasted Sale 

� Other Action 

� Event 

� To-do 

Setup to Schedule Call, Next Action, Appointment, Other Action, Event 

The process is similar for the following activities: 

� Call 

� Next action 

� Appointment 

� Other action 

� Event 
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When you select any of the above activities, a Schedule window is displayed. The Schedule window 
consists of Detail and Users tabs, and you can set up the following parameters: 

Detail Tab 

When scheduling a Call, Next Action, Appointment, Event, or Other Action, the Schedule window displays 
the Detail tab by default.  

In the Detail tab, you can setup the following options: 

 
Figure 56: Schedule a Call in GoldMine - Detail tab 

♦ Contact: While transferring, name of the contact being transferred is automatically displayed here. 

♦ Code: Enter the Job code, or other identifier, to categorize the activity.  

♦ Reference: Enter brief description about the activity. 

♦ Notes: Enter any additional text related to the activity. 

♦ Opportunity/Project: This option is currently not available. 

♦ Primary User: After transfer, the GoldMine user name to which activity is to be scheduled is displayed 
here. The user name is displayed based on the settings in the Users tab. 

♦ Days: Enter the number of days counting from the present day to perform the activity. For example if 
you type 30 days then the activity is executed on the 30th day counting from the present day. 

♦ Time: Enter a time or click the arrow to select time. The Time selector shows the time slots with a 
difference of 30 minutes.  

♦ Duration: Enter the time duration of the activity. For example, if your calls last for 45 minutes, then 
type 45 in the Duration box.  

♦ Ring Alarm: Set an alarm to remind you of the scheduled activity. Select a time from the list. For 

Example: If you select 5 minutes from this list, the alarm pops up 5 minutes before the time at which 
the activity has been scheduled.   
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♦ Private: Select this option to make your activity private. Now the activity is available only to the 
selected user. 

  After transfer, other users can view information about the activity type, date, and user in the Pending tab of the 
contact records. The Reference column indicates that the user designated to the activity is private. In the Calendar, other 

users can view the activity, but cannot view the other details. 

♦ RSVP: Select this option to notify when the assigned user completes the scheduled activity.  

♦ Link: Select this option to attach the activity to the contact record. 

♦ Notify: Select this option to send an e-mail message to user for whom the activity is scheduled, or 
when a scheduled activity is changed.  

♦ Click Schedule to create the activity.  

After transfer, activities are automatically scheduled for the contacts transferred to your database. You can 
view the newly scheduled activity in the Pending tab of the transferred contact. 

Users tab 

In the Users tab, you can assign the scheduled activity to the selected users or user groups. 

 
Figure 57: Schedule a Call in GoldMine - Users tab 

♦ Primary User: Select the primary user from the list.  

♦ User List: Displays the list of all the users. To select a user, double-click the user name. The user 
name is moved to the list under the selected distribution list. 

♦ User Group List: Displays all the user groups. 

♦ Click Schedule to assign the scheduled activity to the selected users. 

Setup to Schedule Forecasted Sale 

A forecasted sale is an estimate to record the anticipated close date of a pending sale with a contact. This is 
different from other activities. You can enter the sale amount, probability of the sales etc., in this activity.   
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In the Schedule a Forecasted Sale dialog box, you can setup the following options:  

 
Figure 58: Schedule Forecasted Sale in GoldMine 

♦ Contact: While transferring, name of the contact being transferred is automatically displayed here. 

♦ Opportunity/Project: This option is currently not available. 

♦ Product: Enter the name of the product or service that the prospect is expected to purchase. 

♦ Code: Enter the Job code, or other identifier, to categorize the activity.  

♦ User: Select the user to assign the activity.  

♦ Units: Enter the number of units of product that the prospect is expected to purchase. 

♦ Price: Enter the cost of each unit. 

♦ Amount: The total cost is automatically calculated (Units * Price) and displayed. 

♦ Probability: Enter the percentage of likelihood of the contact making this purchase. 

♦ Days: Enter the number of days counting from the present day to perform the activity. For example, if 
you type 30 days then the activity is executed on the 30th day counting from the present day. 

♦ Notes: Enter any additional text related to the activity. 

♦ Link: Select this option to attach the activity to the contact record. 

♦ RSVP: Select this option to notify when the assigned user completes the scheduled activity.  

♦ Alarm: Set an alarm to remind you of the scheduled activity. Select a time from the list. For Example: If 
you select 5 minutes from this list, the alarm pops up 5 minutes before the time at which the activity 
has been scheduled.  

♦ Click Schedule to create the activity.  

After transfer, activities are automatically scheduled for the contacts transferred to your database. You can 
view the newly scheduled activity in Pending tab of the transferred contact. 
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Setup to Schedule Literature Request 

If your company has brochures, price lists, and other types of mass-printed documentation, you can 
schedule an activity to send this literature to one or more contacts in your GoldMine database. 

You can schedule a literature request to a user, reminding them to send literature and a cover letters to 
contacts.  

 
Figure 59: Schedule Literature Request in GoldMine 

♦ Contact: While transferring, name of the contact being transferred is automatically displayed here. 

♦ Routing: Select the mode of delivery from the following: 

� Printer 

� FAX 

♦ Cover Letter: Select a form letter to be sent as a cover letter along with the literature. The templates 
displayed in this list are based on the selected user. 

♦ User: Select the user name to view the corresponding document templates in the Cover Letter list. 

♦ Literature List: Select from the list of literature options created in the Literature Fulfillment Center. The 
items included in the list are displayed in the text window below.  

♦ Assigned to: Select the user name to assign the activity. 

♦ Code: Enter the Job code, or other identifier, to categorize the activity. 

♦ Days: Enter the number of days counting from the present day to perform the activity. For example, if 
you type 30 days then the activity is executed on the 30th day counting from the present day. 

♦ Alarm: Set an alarm to remind you of the scheduled activity. Select a time from the list. For Example: If 
you select 5 minutes from this list, the alarm pops up 5 minutes before the time at which the activity 
has been scheduled.  



Create Template in Wizard Mode 

Page 60 

♦ RSVP: Select this option to notify when the assigned user completes the scheduled activity.  

♦ Special Instructions: Enter special instructions required to fulfill the request, such as packing or 
shipping instructions. 

♦ Opportunity/Project: This option is currently not available. 

♦ Click Schedule to create the activity.  

After transfer, activities are automatically scheduled for the contacts transferred to your database. You can 
view the newly scheduled activity in Pending tab of the transferred contact. 

Setup to Schedule To-Do list 

You can schedule activities without specific deadline in a To-Do list.   

In the Schedule a To-do dialog box, you can setup the following options: 

 
Figure 60: Schedule To-Do in GoldMine 

♦ To-do: Enter a brief description for the to-do activity. 

♦ Notes: Enter any additional text related to the activity. 

♦ Priority: Enter a number from 1-9 to setup priority level for the activity. 

♦ Code: Enter the Job code, or other identifier, to categorize the activity.  

♦ User: Select the primary user whose calendar will be updated after scheduling the To-Do list. To 
display a list of available GoldMine users, click on the arrow to the right of the field. . Only those users 
available in your database are displayed here. 

♦ RSVP: Select this option to notify when the assigned user completes the scheduled activity.  

♦ Link: Select this option to attach the activity to the contact record. 

♦ Private: Select this option to make your activity private. Now the activity is available only to the 
selected user. 
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  After transfer, other users can view information about the activity type, date, and user in the Pending tab of the 

contact records. The Reference column indicates that the user designated to the activity is private. In the Calendar, other 

users can view the activity, but cannot view the other details. 

Click Schedule to create the activity.  

After transfer, activities are automatically scheduled for the contacts transferred to your database. You can 
view the newly scheduled activity in Pending tab of the transferred contact. 

The created activities are displayed under Schedule activities while transferring to GoldMine.  

To Edit Activity, 

♦ Select the Activity displayed and click Edit. 

♦ Make the required changes in the Activity Settings and click OK. 

To Delete Activity, 

♦ Select the Activity displayed and click Delete. 

♦ Click OK. 

After creating required activities, click Next. 

12.9.8. User Settings while updating GoldMine 
In the next step, you can setup the options while updating existing records as follows: 

Do not Update User Fields, if incoming data is empty: Select this option so that the data in GoldMine 
User Field is not modified when:  

♦ You have selected to update an existing record. 

♦ Existing record contains data in the user fields. 

♦ Incoming matching record does not contain user field data. 

GoldMine performance setting: Set an optimum level for GoldMine driver’s performance. You can select 
any value between 1 and 15. 

Delimiter for fields mapped to Notes section: 

If you have mapped more than one form tag to the Notes section, you can separate the data by a TAB, a 
Line or any custom character. 
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Figure 61: User Settings for GoldMine 

Under Filing History Options, select the method to save data in the History tab of your GoldMine database. 

♦ Write to History:  Select this option to save an entry in the History tab. 

♦ File in History: Select this option to file the email message in the GoldMine Email Center. 

Select Enable Phone formatting  to save the phone numbers in standard US format. 

After making relevant settings, click Next. 

12.9.9. Setup to attach Process 
In the next step, you can attach process to the transferred contact. 

Select Attach Process after transferring records to GoldMine to enable the processes. 

 
Figure 62: Attach Process to GoldMine 
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All the automated processes created in your database are displayed. Select the checkbox that appears next 
to the automated process. 

  If you have not created any automated processes in your database, then no process is displayed in this dialog box. 

While transferring a contact, the process is attached to the Tracks tab in GoldMine. If you are in the Scan 
Continuously mode, then the process is executed automatically and is attached to the Pending Tab of the 
transferred Contact. 

Click Next. 

The next step is to save the email contents to a text file and attach the file to the destination. Refer to 12.11 

Attach Email Contents to proceed with subsequent steps. 

12.10. Create Template for Outlook 

Select the option Outlook 2007/2003/2002/2000 from the Contact Manager list (Refer Figure 28) and click 
Next. 

In the next step, you need to select the Contact folder to transfer the information. 

12.10.1. Select Folder 
Select the folder that contains the contact records. 

Selected Contact Folder: This option displays the default Contact folder that contains your contact 
information. 

Always transfer to selected contact folder: Under this list select the folder where you want to transfer the 
contact information from email forms.  

After transfer, contacts are created in the selected folder. 

 
Figure 63: Select Folder in Outlook 
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  The selected folder must contain contact items and must be your default address book in Outlook 

Select Contact Form: Every contact folder in Outlook is associated with a form. The form could be your 
customized form or the default contact form provided by Outlook. 

♦ When Posting to this folder, use this Form: Select your customized form from this list. This 
customized form is used to create contacts in Outlook. 

♦ Always use default Contact form shipped with Microsoft Outlook: Select this option to use the 
default contact form to create contacts in Outlook.  

 Customized forms are listed only when you have used them for creating contacts in Outlook 

After selecting relevant options, click Next. 

12.10.2. Filing Information 
In the next step, you can specify the format in which the contact information is filed and displayed. 

Select the filing method from the File As drop-down list.  

 
Figure 64: Filing Information - Outlook 

For example, assume that your email form contains the following values: 

� First Name: William 

� Middle Name: J. 

� Last Name: Stevenson 

� Company: eGrabber 
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This information is filed according to the option you select from the list, as shown in the table below: 

Options Contact Filed in Outlook 

Last Name, FirstName MiddleName 

(This option is selected by default) 

Stevenson, William J 

FirstName MiddleName LastName William J Stevenson 

Company eGrabber 

LastName, FirstName MiddleName (Company) Stevenson,  William J (eGrabber) 

Company (LastName, FirstName MiddleName) eGrabber (Stevenson, William J) 

 

Default mailing address: Select the address section from this drop-down list. The available options are 
Business, Home and Other Address. The selected address is set as the mailing address for the contacts. 

After selecting relevant options, click Next. 

12.10.3. Map Fields 
The next step is to map the database fields available in your Outlook Address Book. 

The settings are similar to mapping fields for Access. Refer to Map Fields in Access Template for more 

details. 

After mapping the appropriate fields click Next. 

12.10.4. Map Email Header Information 
The next step is to extract the email header information and save them in user fields. 

 
Figure 65: Map Email Header Information – Outlook 
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You can save the following information from the email: 

♦ Sent Date. 

♦ Sent Time. 

♦ From Address of the email. 

♦ To Address of the email. 

♦ Subject of the email message. 

Double-click and select the appropriate field to save the above information. 

Copy E-mail to Notes: Select this checkbox to copy the contents of the email message to the Contact 
window in Outlook 

Copy E-mail to History: This option is not available for Outlook. 

Copy and save E-mail attachments to this Folder: Select this checkbox to save the email attachments. 

Click  to browse and select the folder to save the attachment files.  

After selecting appropriate fields, click Next. 

12.10.5. Setup to check for duplicates 
The next step is to setup to check for duplicates. 

To handle duplicate records, select any one of the following options: 

 
Figure 66: Outlook - Check for Duplicates  

Under Select transfer mode,  

• Select Always add as a new contact to add the duplicate as a new contact to your application.  

• Select Update if contact exists to update the existing contact in your application. 
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• Select Warn if contact exists to get a warning message when you transfer a duplicate contact to 
Outlook. During the transfer of a duplicate contact, a Validate Duplicates dialog box appears as 
shown in Figure 40. 

• Select Cancel if contact exists to cancel transferring the duplicate record. 

 

When you select any of the above options except Always add as a new contact, the fields under Select 

Fields for Duplicate Check are made available. Select a single field or multiple fields to check for duplicate 
values.   

Bring Contact to the forefront after the transfer: Select this option to view the transferred Contact. 

After selecting relevant options, click Next. 

12.10.6. Schedule Activity 
In the next step you can schedule and attach activities to the transferred contact records. 

 
Figure 67: Schedule Actitivty – Outlook 

Schedule Appointments, Journals and Tasks  

You can attach and schedule Appointments, Tasks, and Journal Entries for the contacts transferred to 
Outlook. The activity created and scheduled for the transferred contact is displayed in the Activity tab of the 
contact in Outlook. You can attach activities for a single or multiple contacts. 

Click the Appointment, Task, or the Journal buttons to create new activities. 
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To attach an Appointment: 

Click Appointment in the Activity tab. 

Enter the following details in the Appointment Item dialog box: 

 
Figure 68: Attach Appointment in Outlook 

Name: Enter the Appointment name related to your contact. 

Subject: Enter a short description. 

Location: Enter the location. 

Start Time after days: Enter the number of days counting from the present day when you want to perform 

this particular activity. For Example, if you enter 30 days then it executes the activity only on the 30th day 
counting from the present day. 

End Time after days: Enter the duration time when you want the appointment to end for that contact. For 
Example, if you enter 40 days then it ends the activity only on the 40th day counting from the present day. 

Reminder: Select this option and set the time duration you want the reminder to occur before the 
appointment. 

Show Time as: Select from the list to view your appointment time as Busy/ Free/ Tentative or Out of Office. 
This enables others to view your appointment time as specified, when transferred to Outlook. 

Enter a detailed description of your activity in the space provided. 

Categories: Specify a category related to your Appointment. You can specify an item from the Master 
Category List supplied by Outlook or you can enter a new category specific to the activity. 

Private: Select this option to make your Appointment private. 

Click OK to save the Appointment. 

After transfer, this activity is attached and scheduled displaying the name of the transferred contact under 
Contacts. 
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To attach a Task: 

Click Task in the Activity tab. Enter the following details in the Task Item dialog box: 

 
Figure 69: Attach Task in Outlook 

♦ Name: Enter the name of the Task Item. 

♦ Subject: Enter a short description of the Task. 

♦ Due after days: Enter the duration time you want the task to end for that contact. For Example, if you 
enter 40 days then it ends the activity only on the 40th day counting from the present day. 

♦ Start after days: Enter the number of days counting from the present day when you want to perform 

this particular activity. For Example if you enter 30 days then it executes the activity only on the 30th 
day counting from the present day. 

♦ Status: Select the status as Completed/In Progress/Not Started/Waiting for Someone 
else/Deferred related to your task. 

♦ Priority: Select the priority as High/Low/Normal relevant to the task. 

♦ %Complete: Specify the percentage of progress related to the task. 

♦ Reminder: Select this option and set the date and time when you want Outlook to remind you about 
the task. 

♦ Enter a detailed description of your task. 

♦ Categories: Specify a category related to your Task. You can specify an item from the Master 
Category List supplied by Outlook or you can enter a new category specific to the activity. 

♦ Private: Select to make your task entry private. 

♦ Click OK to save the Task. 

As you transfer records to Outlook, this Task is attached to the transferred contact. The Owner’s name is 
displayed under Owner in the Task dialog box. 
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To Attach a Journal: 

Click Journal in the Activity tab. 

Enter the following details in the Journal Entry dialog box: 

 
Figure 70: Attach Journal in Outlook 

Name: Enter a name for your Journal entry. 

Subject: Enter short description related to your Journal entry. 

Entry Type: Select the entry that is related to your contact from this list. 

Start Time after days: Enter the number of days counting from the present day when you want to perform 

this particular activity. For Example, if you enter 30 days then it executes the activity only on the 30th day 
counting from the present day. 

Duration: Select the time duration required to execute the activity. 

Enter a detailed description for the journal entry in the space provided below Duration. 

Categories: Specify a category related to your Journal Entry. You can specify an item from the Master 
Category List supplied by Outlook or enter a new category. 

Private: Select to make your journal entry private. 

Click OK to save the Journal. 

As you transfer records to Outlook, this activity is attached and is scheduled displaying the name of the 

transferred contact under Contacts. The Company name is extracted from the email and is displayed under 
Company in the Journal Entry dialog box. 

 The name of the activity is displayed under Attach selected activities while transferring to Outlook 

2007/2003/2002/2000. You can create more activities by repeating the above steps. You can select/clear the activity 

names to activate/deactivate the process during transfer of contact details.   

After creating appropriate activities to be scheduled, click Next. 
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The next step is to save the email contents to a text file and attach the file to the destination. Refer to 12.11 

Attach Email Contents to proceed with subsequent steps. 

12.11. Attach Email Contents 

You can save the email contents in a text file. 

 
Figure 71: Save the email contents 

Select the Enable checkbox to make use of the options. 

Click  next to Select a Folder to browse and select the folder to save the text file. 

FileName Prefix: Enter a text to appear before the file name. (Example: Cust) 

FileName: Click  to select a database field that is saved as the file name. (Example: FirstName) 

FileName Suffix: Enter a text to appear after the file name. (Example: Order) 

Is the first name is “William”, then the file is saved as Cust-William-Order.txt. 

 If filename is not specified, then the attachment is saved as “untitled” in the specified folder.  

When you transfer multiple form e-mail, the attachment name gets incremented and is saved as Cust-Wiliam-Order1.txt, 
Cust-Wiliam-Order2.txt and so on. 

The maximum length of a filename can be 50 characters. If the filename exceeds this limit then it is automatically truncated 

to the first 50 characters. 

After selecting relevant options, click Next. 
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12.12. Keyword Search 
The next step is to setup to search for specific keywords in the email. 

 
Figure 72: Keyword Search 

For example, you can search for keywords related to sales to identify the customers and save the seacrh 
results in selected fields. 

Select the Enable checkbox to make use of the options. 

Click New to create a name for the seacrh. Enter the name and click OK. 

Under Seacrh Document, you can specify the percentage of the section to be searched. 

Enter the starting section as percentage in the From Top: box and the end section percentage in the To: 
box. The percentage is calculated based on the number of characters available in the email message. 

Under Keywords, enter the terms to be seacrhed for in the email message. 

Select Case Sensitive Search to search for terms that match the upper and lower case letters exactly. 

Under Keyword Matching Criteria, select the method to search for the keywords. 

♦ Any keyword should match: the result is saved in the selected field if one of the searched 
keywords is available in the email message. 

♦ All keywords should Match: The result is saved in the selected field only if all the searched 
keywords are available in the email message. 

Under Store Results of, select the database fields to save the following search results: 

♦ Number of Occurrences: Click  and select the field to save the number of times the keyword 
occurs in the email. 
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♦ Number of Keywords: Click  and select the field to save the total number of searched 
keywords. 

♦ Keywords: Click  and select the field to save the searched keywords. 

After selecting the relevant options, click Next. 

12.13. Select Mail Merge Template 

The next step is to attach a Mail Merge Template to the created template. 

 
Figure 73: Select Mail Merge Template 

♦ Click  to browse and select a mail merge template.  

♦ Click Create Template to create a new mail merge template. 

♦ Click Show Template to view the selected template. 

♦ Click Clear to remove the selected template. 

Refer to Chapter 14 for more details on Mail Merge Template. 

After selecting the relevant template, click Next. 
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12.14. Assign Pre-defined Values 
The next step is to assign default values to specific fields. 

 
Figure 74: Assign default values 

Click  to select the field and enter the value in Pre-Defined Values. Click Add to add the values. 

Now, whenever you transfer contact information from an email form, the default value is saved in the 
selected field. 

For example, you can assign the value Website Feedback Form to the field Account in the database. 

Click Edit to modify the default value and Delete to remove the value. 

After adding appropriate values, click Next. 
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12.15. Save the Template 
The next step is to save the template. 

 
Figure 75: Save the template 

Enter any additional information as Comment and click Finish to save the template. 

The template you have created appears under the Form Processing Center in the eMail-Lead Grabber 
Window. 

You can also use the TemplateMaker to create the templates in advanced mode. 

13. Create Template in Advanced Mode 
Launch the TemplateMaker by any one of the following methods: 

� Select any email that contains all the form tags, right-click and select Create Template in Advanced 
Mode. The Create New Template dialog box is displayed. (Refer Figure 77) 

[OR] 

� Right-Click the Form Processing Center and select Create Template Advanced Mode. 

[OR] 

� Click File>Show TemplateMaker.  

The TemplateMaker window is opened. In this window, click File>New to create a template. 
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Figure 76: Create Template from TemplateMaker 

The Create New Template dialog box is displayed. 

 

Figure 77: Create Template 

From the Select Contact Manager list, select your destination application and click OK.  

The settings are similar to the options explained in Chapter 12 to create a template in wizard mode. The 

setup options vary according to the selected destination. Refer to the section for creating templates for your 
destination in Chapter 12. 

The difference between creating templates in wizard and advanced mode is mapping the fields. You need to 

map the form tags as anchor text and the form data as database fields manually while creating a template in 
advanced mode. 

The following section explains the steps to create a template in advanced mode for Data Export and 
mapping the fields. You can follow the similar method to map fields for other destination applications. 
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13.1. Create Template for Data Export 

In the Create New Template dialog box, (Refer Figure 77) select Data Export from the Contact Manager 
list and click OK. 

 The Data Export option is not available when you create a template in wizard mode. 

The Link Options dialog box appears where you can setup to export the form data as Comma Separated or 
Tab Separated values to a text file. This data can be imported to any application that supports these 
formats. 

In the Data Export Link Options tab, enter the following: 

 
Figure 78: Data Export - Link Options 

Under Transfer Options, you can select the fields to be exported along with the data. 

♦ Export field names: Select this option to export the field names (Name, Address, City and so on) that 
are saved as headers for the fields in the text file. If you do not want to have headers, clear this option. 

♦ Send date and time: Select this option to export the date and time of transfer. 

Under Select field separator, you can select the format in which the data is to be transferred.  

♦ Tab: The data is separated by a Tab space and exported. 

♦ Comma: The data is separated by a comma and exported. 

Under File name and location, you can select the file name and path to save the exported file. 

Click  and select the location. Enter the filename and click Save. 

View: Click to view the file that contains the transferred data. The file displays data only after transfer. 

Clear the file: Click to delete the contents of the file. 

Show list after transfer: Select this option to open the file after transferring the data. 



Create Template in Advanced Mode 

Page 78 

Click Apply to save the settings. 

  The Export field names option is enabled  only when the destination file is not containing any data. Click Clear to 

delete the contents of the file so that this option is enabled. 

13.1.1. Add or Remove User Fields 
eMail-Lead Grabber enables you to create user fields in the CSV file. You can map the user field to fields in 
your email form and export values to your CSV file. 

Example: If the email form contains the field Referred By, the field can be mapped to User1 in the CSV file. 
During the transfer, the value of the Referred By field is transferred to User1 field in your CSV file. 

Click UserFields tab in the Data Export - Link Options dialog box to add or remove user-defined fields. 

 
Figure 79: Add or Remove UserFields in Data Export 

To Add User Field: 

Enter the name of the field in the text box provided before the Add button. Example: Referred By. 

Click Add. The field entered is displayed under UserFields. Click Apply to save. 

To Delete User Field: 

Select the user field name displayed under UserFields. 

Click Remove. The user field name is removed from UserFields. 

Click Apply to delete. 

 You can add or delete the user fields only when the destination file is not containing any data. Click Clear in the Data 

Export Link Options tab, to delete the contents of the file. 

Click OK to save the settings and to map the fields. 
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13.2. Map Fields for Data Export 

After you have setup to export to a text file, the selected email text appears in the TemplateMaker. If you 
have created the template by using the File > New option, then the template appears blank. You need to 
copy and paste your email text that contains all the form tags and data (Refer to Figure 22) in the template. 

In the Template Maker, select the Form Tag including the separator (In the example shown, “:” is the 

separator). Now click  to mark the form tag as Anchor text.  

Select the form data and click  to map the corresponding database field as shown in Figure 80. 

The fields you have setup for Data Export are displayed. Select the field to which the Form Data is to be 
transferred. 

 
Figure 80:  Data Export  - Map Fields 

After mapping all the tags and fields, click File>Save to save the template.  

Enter a name for your template and click OK. 

 You can use the same procedure to map the fields for other destinations. 

Close the Template Maker and you can find the name of the template being displayed under the Form 
Processing Center in the eMail-Lead Grabber window. 

Next, you can setup a Filter to transfer the messages to relevant templates. 

14. Mail Merge Template 
You can create a template to send automatic reply to the email messages processed by your templates. 
This automatic reply can be customized for every prospect by using the concept of mail merge. 

To create a mail merge template, click File > New in TemplateMaker. In the Create New Template dialog 
box, select the Template Type as Email Merge and select your destination from the Contact Manager list. 



Mail Merge Template 

Page 80 

 
Figure 81:Select Template Type 

According to the selected destination, the Link Options dialog box appears and you need to fill in the 

details. These options are discussed under the Create Template in Wizard Mode section. Refer Chapter 12 
for details on the Link Options for your destination. 

After you complete the Link Options, a blank template appears and you need to enter the pre-defined 
message in this window. 

Click  Insert Field Icon to insert the fields from your database in appropriate places as shown in Figure 
82. 

 
Figure 82: Mail Merge Template 

To insert the details from the received message, click Insert > Email and select the appropriate options as 
follows: 

♦ Text:  To insert the contents of the received message. 

♦ Subject: To include the subject line of the received message. 

♦ Date and Time:  To include the date and time. 
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Figure 83: Insert details from received Email in Merge Template 

For every received message, the Merge Template sends an automatic customized reply. 

You can attach the Merge Template to the Email Extract Template so that whenever a message is 
processed by the template, a reply message is sent automatically. Refer to Chapter 12 for details on 
attaching the Merge Template to Email Extract Template. 

15. Bounce Template 
Your email to a prospect may be bounced sometimes due to various reasons. If the email is bounced 

because the email ID is invalid, then you need to delete the invalid email ID from your contact manager to 
avoid future correspondence. 

You can create an Email Bounce Template and transfer the bounced email using this template. This 
template automatically identifies and deletes the invalid email ID from your contact manager. 

To create a Bounce Template, click File > New in TemplateMaker. In the Create New Template dialog box, 

select the Template Type as Email Bounce and select your destination from the Contact Manager list 
(Refer to Figure 81). 

You can create a Bounce Template for the following destination applications only: 

♦ ACT! 

♦ GoldMine 

♦ Outlook 
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15.1. Bounce Email Settings 
The Link Options dialog box appears according to the selected destination. After you login to the database 
and enter other settings, the Bounce Mail Option dialog box appears as shown in Figure 84. 

 

 
Figure 84: Bounce Email Settings 

In this dialog box, enter the following details. 

♦ Delete E-mail address of the matching contact:  Select this checkbox to remove the invalid email ID 
from your database. 

� Paste status in Notes: Select this checkbox so that the changes are saved in the Notes section 
for future reference. 

� Paste status in History: Select this checkbox so that the changes are saved in the History 
section for future reference. This option is not available for Outlook. 

♦ In the Update Field drop-down list, select the database field where you can save the reason for 
deleting the email ID. Enter the reason in the With Reason field. For example, save the reason as 
‘Invalid Email ID’ in the ‘User 1’. 

♦ Click Next. 



Bounce Template 

Page 83 

 

15.2. Exclude Email List 

In the Next dialog box, you can enter the Email Ids that can be excluded from the list of bounced email. 

 
Figure 85: Email Exclude List 

The email IDs entered in this list are not deleted from the database even if they are bounced. 

Click Next and the Save Template dialog box is displayed. 

 
Figure 86: Save the Bounce Template 

Enter your comments and a name for the template and click Finish to save the template. 

Now this Bounce Template appears under the Form Processing Center.  
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Whenever you receive a bounced email, drag and drop the email to the Bounce Template. This template 
searched for a matching contact in your database, deletes the email ID and saves the changes in the Notes 
section. 

This avoids any future correspondence with the invalid email ID when you are using merge template for 
sending messages all the contacts. 

You can also setup a filter that identifies the bounced email and transfers the message to the Bounce 
Template. 

16. Working with TemplateMaker 
The TemplateMaker window contains the following to process the templates. 

♦ Menu bar 

♦ Toolbar 

♦ Status bar 

You can make use of the above components to create, edit or delete the templates. You can test a template 
for proper mapping of fields. 

You can also setup the properties of the Anchor text and the Field mapped by using the Template Maker. 

Refer to Figure 87 that illustrates TemplateMaker with a template created for ACT!. 

 

Figure 87: TemplaterMaker 
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16.1. TemplateMaker - Menu Bar 

The TemplateMaker menu bar contains the following commands: 

File Menu: 

Option Function 

New Create a new template. 

Open Open an existing template. 

Save Save a template. 

Save As Save template with a different name. 

Properties Displays details about the template like Location, Size, Database etc. 

Exit Quit TemplateMaker. 

Edit Menu 

Option Function 

Undo Reverts the last performed action. 

Cut Removes the selected text and places it in the Clipboard. 

Copy Copies the selected text to the Clipboard. 

Paste Inserts the contents of Clipboard. 

Select All Select all the contents in the Template. 

Find Search for a specific text in the Template. 

Find Next Look for the next occurrence of the searched text in the Template. 

 

View Menu  

Option Function 

Toolbar Show or hide the Toolbar.  

Status bar Show or hide the Status bar.  

Anchor Properties Select Anchor text to enable this command. You can modify the 
properties of the selected Anchor text. 

Field Properties Select the Field text to enable this command. You can modify the 
properties of the selected database field. 

Always On Top To display TemplateMaker in front of all open windows. 
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 Insert Menu  

Option Function 

Field Insert database fields 

Anchor Insert Anchor text. 

Email Insert E-mail fields to create E-mail Merge Template.  

 

Process Menu 

Option Function 

Refresh database Update the database settings. 

Extract from Email Extract additional information from the email text and save them in the 
user fields. The email text can be saved to Notes tab. 

Duplicate Check Setup to check for duplicates. This option is enabled for Access, ACT!, 
GoldMine and Outlook templates only. 

Set Process Attaches automated processes. This option is enabled for GoldMine 
template only. 

Lead Source This feature is currently not available. 

Set Activity Schedule activities while transferring contact records. This option is 
enabled for ACT!, GoldMine and Outlook templates only 

Email Header Setup email header values in an Email Merge Template. 

 

Tools Menu  

Option Function 

Mark Form Identifier Set an identifier text for the template to process an email. Once the 
identifier text is set, a message that contains the identifier text alone is 
processed by the template. 

Set/ Change Password Setup a password for the template. 

Test Template Test the template with a sample email for appropriate mapping of fields. 

Delete Templates Delete the selected template. 

Options Launches the Options dialog box to change the settings. 
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Help Menu 

Option Function 

Help Launches Help Topics. 

Send Template If you encounter any problem with a template, click here to send the 

template attached to an email message to eGrabber support. Our support 
team would contact you to solve the problem. 

About TPLMaker Displays information like version number, copyright and license details. 

 

16.2. TemplateMaker – Toolbar 

The TemplateMaker Toolbar contains the following commands: 

Option Function 

 Create a new template. 

 Open an existing template. 

 
Save a template. 

 
Removes the selected text and places it in the Clipboard. 

 
Copies the selected text to the Clipboard. 

 
Inserts the contents of Clipboard. 

 
Insert database fields 

 
Select Anchor text to enable this command. You can modify 
the properties of the selected Anchor text. 

 
Select the Field text to enable this command. You can modify 
the properties of the selected database field. 

 
Insert Anchor text. 

 

Extract additional information from the email text and save 

them in the user fields. The email text can be saved to the 
Notes tab. 

 
Launch Help. 

 The options available in the Menu bar and the Toolbar can also be accessed when you right-click the template. 
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16.3. TemplateMaker – Status Bar 

The TemplateMaker Status bar displays the following details: 

♦ Name of the destination application. 

♦ Database Name or File Name to which the email data is to be transferred. 

17. Customize TemplateMaker 
You can customize the TemplateMaker settings to extract additional information from the email message, to 
setup the anchor text properties, database field properties, setup a password to protect the template etc. 

17.1. Extract from Email 

To extract and save additional information from the email message,  

♦ Click Process > Extract from Email  

[OR] 

♦ Click  in the toolbar. 

In the Extract From Email dialog box that appears, make the following settings: 

 

Figure 88: Extract from Email 

Notes: Select this checkbox to save the email text in the Notes tab of selected database. If you are 
transferring to Excel or Data Export, you can save the email text to a specific column in Excel or specific 
location in the text file. 

The additional information like date, time, sender’s email address, TO address, subject text can be saved to 
user fields in your destination application. 

Click  next to the additional details displayed in the dialog box to select the user field. While transferring, 
the additional information is transferred to the selected user field. 

Click OK to save the settings. 



Customize TemplateMaker 

Page 89 

17.2. Setup Anchor Properties 

Some form tags may contain additional characters. You can mark the form tags as anchor text, and setup 
the anchor properties to search for these additional characters. 

For Example, if your form tag appears as <first>, then the symbols < and > are the leading and trailing 

characters respectively. While transferring, the template needs to identify the text containing these 
characters. You can setup the leading and trailing characters in the Anchor Properties. 

To setup the properties for anchor text, select the text and click  or click View > Anchor Properties. 

In the Properties dialog box that appears, enter the following: 

 

Figure 89: Anchor Properties 

Leading Character: Enter the character that appears before the form tag. Example: < 

Trailing Character: Enter the character that appears after the form tag. Example: > 

Case Sensitive: Select this checkbox to search for form tags that match the upper and lower case letters 
exactly. 

Click OK to save the settings. 

Now the template automatically searches for form tags that contain the special characters and transfers the 
data accurately. 

17.3. Search by using Percentage 

You can search for a certain section of the email message for the form tags and transfer the details. Use this 

option when your email text contains information other than form tags. Enter the percentage of the section to 
be searched by the template in the Search tab of the Properties dialog box. 

Enter the starting section as percentage in the From Top: box and the end percentage in the To: box. The 
percentage is calculated based on the number of characters available in the email message. 

 

Figure 90: Search Properties 
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Click OK to save the settings. 

Now the template searches for form tags available in the specific section and transfers the details. This 

saves time when your email form contains additional information that can be excluded while transferring to 
your application. 

17.4. Setup Field Properties 

You can setup the properties for the database fields to ensure that they are transferred with specific details 
accurately. 

You can setup the maximum field length, field type, format and other attributes. 

Select a database field and click  or click View > Field Properties. 

In the Properties dialog box that appears, you can setup the following: 

17.4.1. Size 
By default, the Size tab appears when you open the Properties dialog box. 

Enter the following to limit the size of the data to be transferred: 

 

Figure 91: Properties - Size  

Field Length Max: Enter the maximum number of characters to be transferred for the selected field. For 

example, if you enter 15 in this box, then the first 15 characters of the form data are transferred to the 
selected field. 

Number of Lines:  Enter the number of lines used by your form data. If your form data is wrapped to two 

lines, then enter the value as 2, to transfer the entire data. If you enter the value as 1, then the data that 
appears in the first line of the form alone is transferred. 

End of document: Select this checkbox to include all the data that appear after the selected field till the end 
of the form. 

Text before anchor: Usually, the form data appears after the form tag. You mark the form tag as anchor 

and the form data as field.  If your email form is containing the form data followed by the from tag, then 
select this checkbox.  

For example, if your form contains data as follows: 

William: FirstName. 



Customize TemplateMaker 

Page 91 

In the above example, William is the form data and FirstName is the anchor. The value William is to be 
transferred to the database field. Select the Text before anchor option to ensure that the data is transferred 
properly. 

Click OK to save the settings. 

17.4.2. Type 
In the Type tab, you can setup the data type of the field. You can ensure that you are transferring only 
appropriate data to your application. 

 

Figure 92: Properties - Type  

Field Type: Select the appropriate data type of the field being transferred. For example, if you setup the 
Phone field type as Numeric, and the field in email form contains alphabets, then the corresponding data is 
not transferred. 

Field start after:  Enter the character that you want to exclude from a form data that appears prior to the 
data while transferring to particular field. For example, if the form data contains a value $1000 and you want 
to transfer only the value 1000 excluding the character $, then enter $ in this box. 

Field end before: This option is similar to the previous one. Enter the character that you want to exclude 
from a form data that appears after the data while transferring to particular field. For example, if the form 

data contains a value 1000# and you want to transfer only the value 1000 excluding the character #, then 
enter # in this box. 

You can mark a value for a particular database field so that the email message is processed only when the 

field contains specific value. For example, you can process the message only if the field Company contains 
the value eGrabber.  

Under Mark Form identifier, select the Field value checkbox to enter the value eGrabber in the text box.  
Refer to Mark Form Identifier section for marking a text from any part of the email message. 

Click OK to save the settings. 
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17.4.3. Format 
Click the Format tab to format the data being transferred. You can setup to transfer the data in specific 
format. 

 

Figure 93: Properties – Format 

Change case: From the drop-down list, select the format in which the field value is to be transferred. 
Assume that the value for Company is eGrabber Inc. The text is formatted as shown in the table.  

Case Output 

None eGrabber Inc. (Value is not formatted) 

Upper Case EGRABBER INC. 

Lower Case  egrabber inc. 

Sentence Case  Egrabber inc. 

Title Case  Egrabber Inc. 

The value is transferred in the selected format to the database field. 

Prefix field with: Enter a text that is added before the transferred data. For example, you can add salutation 
(like Mr. / Ms./ Dr.) to a name as prefix. The name is transferred with the added salutation. 

Suffix field with:  Enter a text that is added after the transferred data. For example, you can add the 
currency symbol “$” after a number being transferred. 

Const value: You can setup a constant value for a specific field. This value is automatically saved in the 

specified field, independent of the data contained in the email form. Select this checkbox and enter the 
constant value in the box. 

Default value: You can setup a default value for a specific field. When the email form is not containing any 
data for this field, then the default value is saved in this field. 

Click OK to save the settings. 
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17.4.4. Values 
In the Values tab, you can replace a value with relevant data. 

For example, if the form data contains the value for State as CA, then you can replace the text with 
California. 

 

Figure 94: Properties – Values 

In the text boxes that appear before the Add button, enter the value that appears in the email form and the 
value to be replaced.  

Click Add to include the values. You can add any number of data by repeating the steps. To edit the values, 
select the text and click Edit. To remove the values, select the text and click Del. 

17.4.5. Lookup 
You can search for a particular value for a field and save a related value to another field. For example, for 
the name field containing value William, you can add the value Sales to the field Department. 

 

Figure 95: Properties – LookUp 

Enter the value of the field to be looked up in the first box, click  to select the field for which the value is 
to be added and enter the value to be added in the last box. 

Click Add to include the data entered. To edit the values, select the text and click Edit. To remove the 
values, select the text and click Del. 
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17.4.6. Field 
In the Field tab, you can save the values from a form tag into an additional field.  

 

Figure 96: Properties – Field 

The Field Name column automatically displays the selected database field name. In the Alternate field 

column, click  to select the additional field where the value is to be transferred. 

Database Field Relationship: 

This option is enabled for GoldMine Business Contact Manager only that can integrate SQL database. 

When your email form contains multiple values for a single field or multiple details for a single contact, you 
can use this option to map the fields and transfer them. 

One to One: You can select this option when you receive multiple values for a single field. 

For example, assume that your form contains the following data: 

 

 

 

 

 

Note that the field Source contains two values, Others and Search Engine. 

When you map the form tag Source as anchor text twice, the second tag is marked as Source1. You can 
map the form data to the same field twice and the second value is marked as Source:1. 

After Mapping, your template appears as follows: 

 

 

 

 

 

 

FirstName: William 

Last Name: Stevenson 

Source: Others 

Source: Search Engine 

 

‹FirstName:› «Contact» 

‹Last Name:› «Last» 

‹Source:› «Source» 

‹Source:¦1› «Source:1» 
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After selecting the One to One option, in the Update Mode list, you can select either one of the following 
options: 

♦ Select the Concatenate option to append the multiple values in the field. If you select this 
option, then the value is saved as “Others, Search Engine” in the field “Source”. 

♦ Select the Lookup and Replace to replace the existing values with the modified data. In 
this case, the first value is replaced with the second value. 

One to Many: Select this option when your email form contains multiple details for a single contact. You can 
transfer the multiple details to user fields for the same contact. 

For example, assume that your Order Form contains following data. 

 

 

 

 

 

 

 

 

 

 

 

 

The contact James Webber is to be transferred to your destination. Note that there are two values for the 

fields ‘Item’, ‘Quantity’, and ‘Description’. Now you need to save these details in the details tab of the contact 
James Webber. 

Item: eMail-Lead Grabber Business 

Quantity: 1 

Description: Single user license 

Item: eMail-Lead Grabber Standard 

Quantity: 2 

Description: Single user license 

Bill to: 

First Name: James 

Last Name: Webber 

E-mail: James@auction.com 
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You can map the values for the same fields. After mapping, the template appears as shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

After mapping, select the Field Properties for the second item (Example: «Item.Reference:1») as One 
to Many and enter 1 in the Field Set option. 

If you have one more item for the same field (Example: «Item.Reference:2), then you need to set this 
option to 2. 

Similarly, select the second item for other fields and set the Field Set option to 1. For more number of items, 
set this option accordingly. 

After transfer, the details for the single contact are transferred to your GoldMine database as shown in 
Figure 97. 

 
Figure 97: Data transferred to Details tab 

You may receive multiple values for fields available in Registration Forms and Feedback Forms. You can 
use the database relationship option to transfer these values. 

Click OK to save the settings. 

17.5. Mark Form Identifier 

You can mark a specific text to identify an email form. The template searches for the marked text in the 

email form and the email message is processed only if the text is found. This ensures that only the 
appropriate messages are processed by the template. 

‹Item:›«Item.Reference» ( First Item) 

‹Quantity:›«Item.Qty» 

‹Description:›«Item.Notes» 

‹Item:¦1›«Item.Reference:1» (Second Item) 

‹Quantity:¦1›«Item.Qty:1» 

‹Description:¦1›«Item.Notes:1» 

‹Bill to:›«Ignore» 

‹First Name:›«Contact» 

‹Last Name:›«Last» 

‹E-mail:›«E-mail» 
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To setup a form identifier, select the text available in your email form and click Tools > Mark Form 
Identifier.  

To mark the form identifier for a database field, refer to the settings for Type tab under the section Setup 

Field Properties. 

17.6. Protect Template 

You can protect your template being edited by other users by assigning a password. 

Click Tools > Set/Change Password. 

♦ In the Add Password dialog box, enter the password in New Password. 

♦ Re-enter the password in Verify Password for confirmation and click OK. 

Save the changes to the template and close the template. 

Now if you try to open the template, you are prompted to enter the password. 

To change the password, click Tools > Set/Change Password. 

♦ In the Change Password dialog box, enter the password in New Password. 

Re-enter the password in Verify Password for confirmation and click OK. 

 Password is case sensitive. Ensure that you provide the exact password text.   

18. Setup Filter 
You can setup a filter that can check the email form for certain criteria. The messages that satisfy the 

specified criteria alone are processed and transferred to destination. You can also send an automatic 
response to every message that is processed by a filter. 

18.1. Create Filter 

To create a filter, 

Click the Filter Icon in the toolbar 

[OR] 

Click Tools > Filters 

In the Filter Setup dialog box that appears, click New to create a new filter.  
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Figure 98: Setup Filter 

Enter a name for the Filter. 

Select the Manual checkbox to process the messages manually. 

Select the Automatic checkbox to process the incoming messages automatically. 

18.2. Setup Criteria 

Under Match Filter Setup, specify the filter criteria. 

Select the relevant column to be checked in the email message from the Header drop-down list. The 
available options are: From, To, Subject, Content, Account. 

Select the matching condition from the next drop-down list. The available conditions are: Contains, Does not 
Contain, Is, Is not, Starts with, Ends with, Is in List. If you select the option Is in List, you need to create a 

text document that contains list of words to be searched in the email message. After selecting the option, 

click  next to the box and select the text file that contains the list of words. 

Enter the text to be matched in the next box. 

In the example shown in Figure 98, the messages with the subject line that contains the text “ELG” are 
processed through the filter. 

18.3. Setup Actions 

Once the messages satisfy the specified condition, you need to specify the action to be performed. You can 
transfer the messages that satisfy specific condition to specified templates.  

Under Action, click the down arrow to select the action to be performed. The following options are available 
in the drop-down list. 



Setup Filter 

Page 99 

Transfer To 

Select this option to transfer the message to selected templates. Click  to open the Choose template for 
filter dialog box. 

 

Figure 99: Select templates 

In the dialog box, the templates are displayed under Available Templates.  

Select the relevant template and click Add. 

Now the template is displayed under Template chosen for the filter.  

To remove a template select the chosen template and click Remove. 

Click OK to save the settings. 

Reply with 

Select this option to send an automatic response to the processed email message. You need to create 

Stationery for sending the auto response. Select the Stationery file from the drop-down list. Whenever a 
message is processed by the filter, a response is sent to the sender of the message as per the settings you 

have made in the Stationery file. Refer to 18.4 Create Stationery section for more details. 

Size Limitations 

You can setup to limit the size of the email message to be processed. You need to specify the maximum 

size limit. For example, if you specify the size as 1000 KB, then messages exceeding the size 1000 KB are 
not processed by the filter. 

Date Range 

You can use the Date Range option so that messages that contain dates within the specified range alone 
are processed. Enter the From and To dates to specify the date range. 

Round Robin Forwarding 

You can use this option to distribute the email messages to your team members in a repetitive cycle. 
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This enables you to distribute work among your team members effectively. 

For example, assume that the marketing team consists of three members with email IDs as follows: 

♦ wiiliam@egrabber.com 

♦ richard@egrabber.com 

♦ mark@egrabber.com 

Now Round Robin Forwarding can be setup so that William received the first email, Richard receives the 
second, Mark – the third and William again receives the fourth email. This cycle is repeated. 

In the Filter Action, select Round Robin Forwarding from the list. In the next box, click  to open the 
Round Robin Forward dialog box. 

Click New  to create a new set of email ID list. Enter the email IDs one below the other and click Save. Enter 
a name for the group of email IDs and click OK.  Now the dialog box appears as shown in Figure 100. 

 
Figure 100: Round Robin Forwarding 

♦ Click New to create another group. 

♦ Click Save As to save the group with a different name. 

♦ Click Delete to remove the group. 

♦ Click Close. 

Now the created groups are available in the drop-down list next to the Round Robin Forwarding Action. 

 
Figure 101: Round Robin Forwarding selected in Filter Action 

Select the required group and save the filter. 

Now whenever a message is processed by the filter, it is also sent to the marketing team member for follow-
up. 
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Round Robin Processing 

You can use this option to transfer the email messages to various templates in a repetitive cycle. 

Round Robin Processing enables you to process the messages through a set of selected templates in a 
cycle. The messages that satisfy the Filter Criteria can be processed through different templates. 

In this method, you can process the first message through first template, second message through the 

second template and so on. If you have specified three templates, then the fourth message is processed 
through the first template and this cycle is repeated. 

When you are distributing email messages to the team members, they can maintain different database for 

saving the contacts. You can create different templates and map them to respective database maintained by 
your team members and use Round Robin Processing to save the contact details in corresponding 
database.  

This enables your team members to follow up with the contact in their database effectively. 

In the Filter Setup, select Round Robin Processing from the Action list.  

Select the Template Group from the available list. To create a new group, click next to the option. 

In the Round Robin Process window that appears, setup the following options: 

 
Figure 102: Round Robin Processing 

♦ Select the name of the group from Groups list. 

♦ To create a new group, click New on the Template Group menu. 

♦ Enter a name for the group. 

♦ Under Available Templates, Select the Templates to be added to the group and click  

♦ The added Templates are displayed under Templates in Group. To remove a Template from this list, 

select the Template and click . 
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♦ To add all the Templates to the group, click Add All. 

♦ To remove all the Templates from the group, click Remove All. 

♦ To save the group, click Save or Save As on the Template Group menu. 

♦ To delete a group, select the group name from the list and click Delete on the Template Group menu. 

Click Close on the Template Group menu. 

In the above example, the first message is processed through GM6_Sample; the second message through 
GM7_Sample and the third message is processed through GM_Sample. The fourth message is again 
processed through GM6_Sample and the cycle is repeated. 

Now the created groups are available in the drop-down list next to the Round Robin Processing Action. 

 
Figure 103: Round Robin Processing selected in Filter Action 

Select the required group and save the filter. 

Now whenever a message is processed by the filter, the contact details are saved in corresponding 
database for effective follow-up. 

Skip Rest 

When you have setup multiple filters, an email message is processed through all the filters one by one. If 

you want to stop processing a message that satisfies a condition through all the filters, you can select this 
option. 

For example, assume that you have the following filters. 

♦ Filter1 

♦ Filter2 

♦ Filter3 

In Filter1, if the subject of an incoming email contains the text eMail-Lead Grabber then the email to 
transferred the specified template.  

If you want to stop the message being processed through Filter2 and Filter3, then select the option Skip 
Rest. 

If a message satisfies the specified condition, then it is not processed by rest of the filters. If the message 
doest not satisfy the condition, then it is processed by the other filters. 

When you use multiple filters, the Skip Rest action enables fast processing of email by the relevant filter 
and avoids unnecessary processing of email by the other filters. 

Repeat the above steps to create more number of filters. 
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18.4. Create Stationery 

When you receive an email form from a prospect, you need to send a response to the message. Instead of 
sending these reply messages for each and every email form, you can create a Stationery with customized 
message and link the Stationery with the Reply To action in Filter Setup. 

Whenever an email message is processed through the filter, the Reply To option sends an automatic 
response to the message by using the selected Stationery. 

Click Tools> Stationery. 

In the Stationery dialog box, click Add to create new Stationery. 

 
Figure 104: Create Stationery 

A new message window appears as shown in Figure 105. 

The From column automatically displays the email ID you have provided in the Account Setup. If you have 

created more than one account, then you can select the account from the drop-down list. The response 
message is sent using the selected account. 

In the TO: column, enter the email ID of the recipient. If you are attaching the Stationery to a filter, then the 
TO: address is automatically detected. 

Enter a Subject line. 

The checkbox Include Incoming email while responding is selected by default. This option includes the 

text of the original message while sending the auto response. You can clear this checkbox if you do not want 
to include the original message. 

Use Incoming subject while responding: Select this checkbox to include the subject line of the incoming 
email in the auto response. The Subject line is disabled when you select this option. 

Type your message text and save the Stationery. Click Save or Save As and enter a file name to save the 
Stationery. The Stationery files are saved with the extension .sta 
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Figure 105: Sample Message to be sent as Auto Response 

Click Attach to browse and select a document that can be attached to the sent messages. For example, you 
send your company’s brochure as attachment along with all the responses. 

If you want to send an email message to an individual immediately, enter all the details and click File > 
Send. 

Once you save the Stationery file, the filename appears in the Stationery dialog box. 

To modify the details of a Stationery, select the appropriate filename and click Edit. To delete a Stationery, 
select the filename and click Remove. 

After creating required Stationery files, you can attach them to the Reply With action in appropriate filters. 

Whenever a message is processed by the corresponding filter, an auto response is sent to the sender of the 
email message by using the selected Stationery. 

Refer to the Filters–Reply With section for attaching the Stationery file to a filter and send automatic 
responses to all the processed messages. 

18.5. Working with filters 

To process a message through filters, select the message in the eMail-Lead Grabber Inbox. To process all 
the messages, select all the messages by pressing CTRL + A. 

Now right-click in the message grid and select the option Process through Filters. The messages are 
processed through all the filters you have created. 

If you have selected the Automatic checkbox while creating a filter, then whenever a new message is 
downloaded into eMail-Lead Grabber Inbox, the message is automatically processed by the filter. 



Maintenance of eMail-Lead Grabber 

Page 105 

19. Maintenance of eMail-Lead Grabber  
As you receive more number of messages, your mailbox may occupy more space in the hard disk and it 
becomes difficult to manage large number of messages. 

You can use Dr. Mailbox utility to backup the old messages and to compact the mailbox. Dr Mailbox is a 
wizard based utility to compact, backup, repair, clean / backup and migrate Mailboxes. 

This enables you to clear the hard disk space and to manage the messages in eMail-Lead Grabber Inbox 
efficiently. 

Click Tools > Backup / Compact to open the Dr. Mailbox utility. 

 
Figure 106: Dr. Mailbox to mainatin the Mailbox 

In the dialog box, select one of the following options and click Next: 

Compact Mailbox: To compact the mailboxes that exceed the size limit. The mailboxes that exceed 45 MB 

size appear in red color in the next dialog box and require compaction. These mailboxes are selected by 
default for compaction. 

Backup Mailbox: To have a backup copy of the mailboxes. 

Repair Mailbox: To find and fix the errors. 

Clean/Backup Mailbox: To clear the messages in the selected mailbox and copy a backup of the mailbox. 

In the next dialog box, the mailboxes available in eMail-Lead Grabber are displayed. Select the mailboxes to 
be processed by selecting the check box that appears prior to the Mailbox. 

Click the appropriate option. 

Since eMail-Lead Grabber needs to be closed during the compaction/backup process, a message appears 
prompting you to close eMail-Lead Grabber. 

Click Abort to stop the compaction process. 

Click Finish. 

Once the compaction / backup is completed, eMail-Lead Grabber is launched automatically. 
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Migrate Mailbox 

You can use this option to import mailbox (with *.ebx extension) into eMail-Lead Grabber from a different 
email application. 

Select Migrate MailBox and click Next. 

Click Browse and select the mailbox to be imported into eMail-Lead Grabber. 

Since eMail-Lead Grabber needs to be closed during the migration process, a message appears prompting 
you to close eMail-Lead Grabber. 

Click Finish. 

Migrate Template 

You can use this option to import templates (with *.etf extension) created in previous versions of eMail-Lead 
Grabber into the current version.  

Select Migrate Template and click Next. 

Click Browse and select the template to be imported into eMail-Lead Grabber. 

Since eMail-Lead Grabber needs to be closed during the migration process, a message appears prompting 
you to close eMail-Lead Grabber. 

Click Finish. 

Whenever you mailbox is overloaded with large number of messages, launch the Dr. Mailbox utility to 
compact, backup and make more space in your hard disk. This improves the efficiency of eMail-Lead 
Grabber. 

20. Automatic Processing of email 
Now that you have setup to download the messages, setup the filter and created a template for your 
destination, just launch eMail-Lead Grabber and minimize the application.  

If you have setup to download and filter the messages automatically, then you need not intervene with the 
application.  

eMail-Lead Grabber automatically downloads the email messages whenever you receive an email form from 
your website, filters them and transfers the contact and additional details to your destination application. 

If you have attached Stationery to the filter, then an automatic response is sent to the processed messages. 

This enables you maintain all the leads generated from your web form and to follow-up with the leads. 
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21. Ready Reckoner 
The following list provides the shortcut keys for your ready reference. 

 

Figure 107: Ready Reckoner
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22. License Agreement  
This legal document is an Agreement between you, the end user, and eGrabber (THE COMPANY). By 
installing this software, you are agreeing to become bound by the terms of this agreement, which includes a 
software license and disclaimer of warranty. 

This agreement constitutes the complete agreement between you and the company. If you do not agree to the 
terms of this agreement, do not install the software. Promptly return the package and the other items that are 
part of this product to the place where you obtained them for a full refund. 

1. GRANT OF LICENSE - THE COMPANY grants to you, the licensee, a royalty free non-exclusive right to 
use this copy of computer program (the "Software") with the terms set forth in this document. 

2. OWNERSHIP OF SOFTWARE - THE COMPANY retains title and ownership of the software recorded 
on the original media and all subsequent copies of the software. 

3. COPY RESTRICTIONS - The software and accompanying written materials are copyrighted. Unauthorized 
copying of any part of the software or of any accompanying written material is expressly forbidden. However, 
you may make one copy of the software for your personal backup purposes. You are not permitted to make 
any copy of the printed material accompanying the software. 

4. BACKUP THIS SOFTWARE - IT IS YOUR RESPONSIBILITY TO MAINTAIN A BACKUP COPY 
OF THIS SOFTWARE ON ANOTHER PC OR ON A CD, FOR USE IN THE EVENT OF 
CATASTROPHIC LOSS SUCH AS HARD DISK CRASH OR LOSS OF YOUR WORKING PC IN ANY 
OTHER MANNER.  

As a courtesy, THE COMPANY will maintain links to download our software that were sold in the past 365 
days on THE COMPANY’S support web page. If the version of software you purchased is not on the support 
web page, you will be able to purchase the latest version at the published upgrade price for the software, after 
you provide proof of owner of the original software.  

5. TRANSFER RESTRICTIONS - This software is licensed only to you, and you agree that you will not 
transfer, rent, loan, sub-license or host the software without the prior written consent of THE COMPANY.  

You may only make a one-time permanent transfer of the software in its entirety to another end user, provided 
you retain no copies and you transfer all of the software product including all component parts, media and 
printed materials, upgrades, this license agreement AND the recipient agrees to the terms of this license 
agreement. 

6. TERMINATION - The License is effective until terminated. The License will terminate automatically 
without notice from THE COMPANY if you fail to comply with any provision of this license. Upon 
termination, you must destroy the accompanying written materials and all copies of software. 

7. DISCLAIMER OF WARRANTY - THE COMPANY does not warrant that functions contained in the 
software will meet your requirements, or will operate in combinations which may be selected for use by you, or 
that the operation of the software will be uninterrupted or error free, or that any defects that may exist in the 
Software will be corrected. Errors may exist in the software. 

8. REVERSE ENGINEERING - You may not yourself or through a third party reverse engineer, decompile 
or disassemble the software except, and only to the extent such activity is expressly permitted by applicable 
laws notwithstanding this limitation.  

9. PARTIAL USE - This software may not be used in whole or in part to enhance, create or otherwise assist in 
the development of a similar competitive product without express written consent from THE COMPANY.  

10. UPGRADE - If this software is issued as an upgrade, you must be properly licensed to use the product 
identified by THE COMPANY as being eligible for the upgrade. Following the upgrade, you may use the 
resulting upgraded software only in accordance with this license agreement and you may not sell or re-use the 
upgraded product or the original product.  
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11. UPDATES - Certain components of this Software requires to be updated automatically from time to time 
due to changes in Address formats and Web page formats which are not within eGrabber's control. You shall 
have the right to obtain Component Update(s)free of cost only for 90 Days. However, You can purchase 
subscription to Component update(s) for additional fee after the free period of 90 Days to continue receiving 
such updates, but for the subscribed period only. This License does not otherwise permit the licensee to obtain 
and use Component Updates. 

12. RESERVATION OF RIGHTS - THE COMPANY reserves all rights not expressly granted to you in this 
license agreement.  

13. LICENSE KEY - You may not disclose to any other person or organization your license key. You agree to 
store it and keep it confidential and to notify THE COMPANY immediately if you have any reason to believe 
that you lost your license key.  

14. LICENSE KEY REGISTRATION - There are technological measures in this Software that are designed 
to prevent unlicensed or illegal use of the Software. You agree that THE COMPANY may use these measures 
to protect against software piracy. This Software may contain enforcement technology that limits the ability to 
use the Software on multiple computers. This Agreement and the Software containing enforcement technology 
require license key registration as further set forth during installation and in the Documentation. 

15. HOSTING - You may install the software on ONLY ONE PC at any given point of time and you may not 
permit or enable other individuals to use the software over a public access network of any kind including, but 
not limited to, internet, intranet, bulletin boards, phone or mobile; unless you receive specific written consent 
to do so from THE COMPANY. 

16. RESTRICTIONS ON USE - You may not sell information captured using this software or reproduce, 
display, publicly perform, distribute, or otherwise use the captured information in any way for any public or 
commercial purpose. The use of the captured data on any other web site or in a networked computer 
environment for any purpose is prohibited. This license explicitly prohibits captured data from being placed on 
a server for access to others outside the company. This License explicitly prohibits re-broadcasting or sale of 
the captured data in any form. This license is not for use by service providers to provide data extraction 
services to multiple clients using the same license key. The captured data should be for company's internal use 
only.  This License permits the use of the software only by the end user to extract data by their company or one 
end client for the purpose of using the extracted data by the company.  

17. PIRATING OF DATA IS PROHIBITED - Some third party web sites and portals prohibit the use of 
automated capture tools like this software to capture data, and other sites place restrictions on how captured 
data can be used. This agreement expressly prohibits the use of this software to capture data from such third 
party web sites and documents, as well as using such captured data in a manner where it is illegal to do so.  
THE COMPANY can offer you no opinions on the legality of capturing any data, even if capability to capture 
such data is included in this software. It is your responsibility to make sure you have the relevant rights to 
capture and store the data the way you plan to, before using this software.  

18. DISCLAIMER - THE COMPANY is not affiliated or connected in any manner to any third party web 
sites, including but not restricted to, online directories, listings, job boards, yellow pages and white pages. THE 
COMPANY recommends you to read license agreements of these third party web sites and ensure you do not 
violate any Government Laws or rules of the third party web sites before using the software. You agree that 
THE COMPANY is not responsible for any such violations committed by you using the software.  

DO NOT USE THE SOFTWARE IN ANY CASE WHERE SIGNIFICANT DAMAGE OR INJURY TO 
PERSONS, PROPERTY OR BUSINESS MAY HAPPEN IF AN ERROR OCCURS, YOU EXPRESSLY 
ASSUME ALL RISK FOR SUCH USE. THE SOFTWARE AND ACCOMPANYING WRITTEN 
MATERIALS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND.  
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THE COMPANY DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS 
REGARDING THE USE, OR THE RESULT OF THE USE, OF THE SOFTWARE OR WRITTEN 
MATERIALS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS OR 
OTHERWISE. YOU ASSUME THE ENTIRE RISK AS TO THE RESULTS, QUALITY AND 
PERFORMANCE OF THE SOFTWARE. IF THE SOFTWARE OR WRITTEN MATERIALS ARE 
DEFECTIVE, YOU ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING OR REPAIR 
OR CORRECTION. 

THE COMPANY MAKES NO WARRANTIES OF ANY KIND, EXPRESSES OR IMPLIED, 
INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND 
FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THIS PRODUCT. NO ORAL OR 
WRITTEN INFORMATION OR ADVICE GIVEN BY THE COMPANY, ITS DEALERS, 
DISTRIBUTORS, AGENTS OR EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY 
INCREASE THE SCOPE OF THIS WARRANTY, AND YOU MAY NOT RELY ON ANY SUCH 
INFORMATION OR ADVICE. 

NEITHER THE COMPANY NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE 
CREATION, PRODUCTION, OR DELIVERY OF THIS PRODUCT SHALL BE LIABLE FOR ANY 
DIRECT, INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES (INCLUDING DAMAGE 
FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS 
INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OF OR INABILITY TO USE THIS 
PRODUCT, EVEN IF THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES. 

Some states do not allow limitations on how long an implied warranty lasts, or exclusion or limitation of 
incidental or consequential damages, so the above limitations and exclusions may not apply to you. This 
warranty gives you specific legal rights, and you may also have other rights, which may vary, from state to state. 

19a. LIMITATION ON SUIT - You agree that any suit or other legal action or any arbitration relating in any 
way to this Agreement or to the software MUST be officially filed or officially commenced no later than ONE 
(1) YEAR after the software is received by you. 

19b. LIMITATION OF LIABILITY - IN NO EVENT WILL THE COMPANY OR ITS SUPPLIERS BE 
LIABLE TO YOU FOR ANY DAMAGES, CLAIMS, OR COSTS WHATSOEVER OR ANY 
CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGES, OR ANY LOST PROFITS OR LOST 
SAVINGS, EVEN IF A COMPANY REPRESENTATIVE HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS OR FOR ANY CLAIM BY ANY 
THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT 
PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. THE COMPANY'S AGGREGATE 
LIABILITY AND THAT OF ITS SUPPLIERS UNDER OR IN CONNECTION WITH THIS 
AGREEMENT SHALL BE LIMITED TO THE AMOUNT PAID FOR THE SOFTWARE.  

20. GOVERNING LAW AND FORUM - All disputes arising out of, under, or related to this Agreement will 
be brought exclusively in the state or federal courts located in Santa Clara County, California, USA. 

21. COMPLETE AGREEMENT - This Agreement is the complete software license agreement between you 
and THE COMPANY, and supersedes all prior negotiations, agreements, and understandings concerning its 
subject matter. The interpretation of this Agreement may not be explained or supplemented by any course of 
dealing or performance, or by usage of trade. 

If you have any questions concerning this Agreement, or if you desire to contact THE COMPANY for any 
reason, please contact in writing. 
eGrabber Inc. 
1340 S. De Ana Blvd., Suite #106 
San Jose, CA 95129 
USA 
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